Collision Editor Malfunctioning


(Alexander) #1

Another issue has arisen for me thats probably somehow my fault but I guess we’ll see.

I’m opening up my Tile Collision Editor and as soon as I do the Zoom in and out percentage box is highlighter and I can’t add a collision or move around the tile. It only lets me change the magnification.

Not that this picture displays the problem I hope it helps.

Also when I had another Tileset open it would only make really large selections of the Tile it wouldnt fit around the pixels.

I’ve tried restarting; Tiled, Unity, Tiled2Unity and my computer. I’ve deleted the Tileset off my Scene which means I have to everything all over again. I thought it was my keyboard or mouse messing up so I unplugged and plugged them back in.
I even ran Tiled in compatibility mode!

If anyone knows what’s up please help.


(Thorbjørn Lindeijer) #2

This happens when your tileset is external to the map, because the current version of Tiled can’t track changes to other files than the map files (for undo/redo and saving). To work around that issue, temporarily import the tileset using the small button below the tileset view, and export it again to the .tsx file when you’re done.

This is one of the main issues I’m working on to fix for the next Tiled release.

That’s probably because you had snap to grid on. You can disable it, or use snapping to the “fine grid” (configurable in the preferences) for more useful snapping, or get a Tiled snapshot build which has a new option to snap to pixels.


(Alexander) #3

Thanks a bunch!


(Thorbjørn Lindeijer) #4

The Tiled snapshot builds now include the changes necessary to make external tilesets directly editable. If you’re still in need of doing this sometimes, please give them a try. Feedback is welcome!