How to set Tile properties now

Hey guys, it’s been a while that I didn’t use TileMap Editor and I’m kinda lost right now. When I used it for the last time, we were in 2013, the only task we had to do was :

  • right click on the Tile we want
  • click “Tile Properties

Then, a little window was there to allow us to name our properties ! Some lines of code latter, everything was ready and functional.

Now, I tried to do right click, I choose “Tile Properties” but there is no window anymore, now it’s a sort of big tab on the left and I can’t name or set anything with it. I don’t understand what I’m supposed to do with that. If someone can explain me how TileMap Editor works today (I mean, to set my Tile properties), I’ll be glad.

Thanks !

After choosing “Tile Properties…”, you should see a window like this somewhere (docked by default, but it can be floated as a window if you prefer):

You can use the “+” button to add custom properties to this tile.

1 Like

Oh god I didn’t see the little “+” in the bottom, it’s tiny and gray with me, your is big and green. Fuu.

Anyway, thank you mate. This topic is solved !

If it’s gray, your tileset is probably external, and you’ll need to (temporarily) import it and then export it again after adding your tile properties. Eventually I hope to get rid of this oddity, of course.

Here’s what I’ve got when I tried to add properties…my screen is really different than yours and the properties doesn’t seems to be saved even if I save my work, for example :confused:

I write the name of my property, but then it’s like every other tiles have it too…it’s less clear than before, when I used this editor in 2013 ! Do I really have to import my tileset for finally export it to fix that ? :laughing:

Edit : I checked and it’s okay, as I said, it works now. Topic solved x)

So I see you solved the problem, but I’d still thought I’d clear up the confusion here. The button you have highlighted in your screenshot is the “Tileset Properties” button, not the “Tile Properties” button. To edit the properties of a tile, you would just click the tile.