Where do I add PNG files in Tiled?

I know this has been discussed a lot, and I was under the impression that it was fixed long ago. I had an old version (latest on LInux Mint via the standard repositories) and couldn’t get Tiled to accept PNG files (individual or tilesheets), nor would it expect tsx files converted from png. So I downloaded and installed the real latest version (1.3.1) and now, I’m still seeing the same thing, both when I drop the image into the main map area and into the Objects area.

When I try and drag/drop a single-image png (i.e., not a sheet), I get this error:

Error opening ‘/home/jim/gamedev/Resources/CC0/NotUsingNow/cargo.png’:
Unrecognized file format.

The one thing I never did see in the solution is where the correct place is to drop that file. I tried the same with a tsx that had been converted from the png (convert foo.png foo.tsx) and it did the same thing.

I’m looking for a simple editor to create platforms “offline” (in this case meaning, before opening GDevelop), and if I remember from about 6–7 years ago (at least), Tiled was great for that. But that was when my old Mac Mini was still alive. Now I’m on Linux Mint 18.3 with Cinnamon, and while I don’t think that should make any difference in how to use Tiled, Mac OS X did screw around with a bunch of normal Unix stuff, so who knows…

If there’s any relevant information that I’ve failed to include here, please let me know and I’ll include it in a reply. With that in mind, can anyone tell me how and where to add those png files that make up sprite sheets (that give the same error—I think I mentioned that, if not, I meant to).


PS: Please excuse any errors above that I might not have caught. I’ll skip the details that no one is likely interested in and just say thank cancer #1 and its second metastasis, three brain tumors, followed by three very severe brain surgeries and then whole-brain/max-dose radiation therapy, and the locations of two of those tumors (left side). I usually feel them before I see them, and if I don’t, the damage from one of those might keep me from seeing the error, but instead show me what I meant to type.

Hey @Jim_Graham, welcome to the Tiled forums!

You’re running into a basic usability issue. The expected way to create a tileset, is to use File > New > New Tileset and then to pick the image, or to drag your image into the Tilesets view rather than onto the main editor view, which spawns the same dialog with the image path already filled in (to see the Tilesets view, you first need to open or create a map).

The reason that it doesn’t work on the main view, is that it’s not clear towards Tiled what you want to do. If there’s a map already open, dragging an image could mean any of:

  • Create a new tileset based on that image
  • Add a tile object referring to that image (then of course it needs to be added also to an existing or new image collection tileset, if it’s not already in one)
  • Add an image layer referring to that image
  • Open the image (suppose Tiled also has a basic image editor)
  • Create a new map based on that image, automatically creating a tileset alongside with all the unique tiles (a requested feature)

Granted, the option to create a new tileset may be the most commonly expected one so when the file format is not recognized and it loads fine as an image, it could be a good idea to do the same as when dragging an image onto the Tilesets view.

Thanks. I just found out that, surprise surprise after what my first cancer did, my memory about Tiled was wrong. It’s apparently not a great tool for making platformer levels. Oh well. Anyways, I definitely appreciate your help with this, even if it did tell me I was trying to do things the wrong way. :slight_smile: