Crashing after update

Can’t start Tiled after update. Get this error:

Edit: Reinstalled 0.18.1 and now it works.
Did you remove the need of tsx files for tilesets? and that one was forced to save new files?
I might used some old version, but it works now :slight_smile:

There is a problem with the Windows installer when doing upgrades, which is related to a change I made to have the installer do a proper system-wide install instead of a half-baked user install that anyway required administrator privileges. I didn’t expect that to break things, but it did and I could not find a way to do this change in a better way.

I should probably add a note about this to the release notes. When I noticed it, I only added a message to the updater notification window about needing a reinstall.

I’m not sure what you mean by this question. Using tsx files for tilesets was and remains optional. Though in the development snapshots (not 0.18.1), the usage of tsx files is recommended over using embedded tilesets.