.tsx files gone

I made a small world with a basic tileset yesterday, but today all of the .tsx-files were gone and the tilesets didn’t load. This is my first time using Tiled btw :slight_smile:

When you reopen the map, doesn’t Tiled present you with the list of .tsx files that it can’t find?

In any case, if you open the map file in a text editor you can see the references to the .tsx files. Can you find these files yourself? If the issue is not actually the .tsx files but the images, open the .tsx files in a text editor and check the references to the image files. The paths are always relative to the file they are stored in.

And in case you figure it out, be sure to let us know what the problem was.

1 Like

I knew where the files were before, but they’re gone now. I’ve looked through the whole map, but I don’t have a clue to where they might have gone.

I don’t understand. You need to look for the files on your file system. The relative paths to the files can be found in the tmx and tsx files, if you open them with a text editor.

Tiled does not generally delete files from your file system, so if they were once there they should still be there.

1 Like

I solved it! The files were in another location. I don’t know how this happened, but that’s probably something from my side. I had to simply re-arrange everything and it worked again! :slight_smile:
Thank you very much!!!

1 Like

That’s why I prefer embedding tilesets directly in map. They won’t add much to the map’s “weight” (unless there are a lot and I mean a lot of them) as they contain only very basic info (I think it’s just image file path, tileset’s name and tile size) and it prevents stuff like that from happening, unless you misplace the tileset graphic itself.

If indeed you don’t add any additional information to your tileset then they will only contain basic info. But as soon as you start using tile properties, collision shapes, animations or terrain / Wang tiles, it really makes sense to store them separately.

I see the option to embed the tileset as purely historical and wouldn’t recommend it.