Creating Walls with Terrain Tool

Okay, so I’m new to Tiled but I absolutely love this program! I’ve spent the past hour and a half trying to figure this out; the closest I came was something about automapping a cave wall in this forum, which I’m not quite sure is what I want. So, here’s my issue: I am trying to create a wall using the following tileset I find on open game art:

You can see two, possibly three images that can be used to to make a terrain on the top left corner of this. I make the following selection:

I’ve tried several other ways of selecting it, but this seems to be the only way the wall comes out semi-decent. Still, if I paint too fast, I get the following:

For one, I have no idea where these stupid gray spaces keep coming from. The walls themselves also seem off from what it should be. Also, I have to press and hold control to even get this kind of image. Lastly, the corners are incorrect. If you look at the sample that came with the tileset, it should look as follows:

So my question is: what on earth am I doing wrong? And how do I fix it? I appreciate any help that can be given to resolve this!!!

You can’t really paint terrain without having at least one tile that is entirely filled with that terrain. This is why you’re only seeing some results while holding Ctrl, since that makes it modify only part of a tile.

Fortunately, you have only black outside of your wall, and you can use that as the base terrain tile. The wall itself then becomes part of its transition to “something else”. So the following setup would work:

Thank you for your response! Unfortunately, that setup didn’t work. When I tried that, it only let me paint in black - even when I held control down. Any other suggestions?

Hmm, maybe you did something a little differently? It worked fine for me:

(currently have the tool set to Erase Terrain)

Edit: Of course, I realize this is the “wrong way around”, but you could just fill the map with the black tile and then use the terrain tool in erase mode to create space for the rooms.

I’m not sure about this erase mode your talking about; I only see an erase mode for modifying the actual terrain I created. With that said, I think I found the solution!

I just deleted the background making it all gray like yours was. Then, I was able to use the terrain tool normally. Afterwords, I can just use the fill button to fill the background to be black. If I need to make a change, no problem, just make the background gray again, make the changes, and then fill back in black. Thanks a lot for your help!

I was talking about the erase mode of the terrain tool. This is activated by clicking the “Erase Terrain” button below the Terrains view while having the Terrain Brush selected.

I’m glad to hear you got it to work!


Gotcha, yes, that makes a lot of sense. I was able to figure it out that way too.

I actually had a follow up question for you too, if you wouldn’t mind…

How can I make that black that’s inside these walls transparent? Not the walls themselves, but just the black? I’m trying to add a floor to this. I can’t really use layers to resolve this problem, as either the floor covers the edge, or the whole wall including the black covers the floor!

Trying not to be frustrated here, but…I opened gimp and edited the tileset so that I can remove the black and make it transparent. The problem is that after I load this into Tiled as a new tileset and created the terrain, it won’t let me use it. It will only let me pick terrains I created from my first tileset… What can I do to fix this?

Hmm, are you using Tiled 1.0.2? It contains a bug fix for terrains not showing up. See the following topic:

I must have just missed it, as the version I was working with was released sometime in late May. I ended up using the workaround found in the thread, and I have also downloaded the newest version of Tiled. That being said…I’m back to being stuck with my original problem:

I have the grey, transparent background (rather than the whole thing being black). I used GIMP to edit the tileset and remove the black from the wall tiles. I then selected it exactly like you showed me before…yet now, I can’t draw the walls at all!!! What am I doing wrong this time?

I’m afraid you’d have to share your files otherwise I have no idea what’s up.

No problem:

Here, I am simply trying to work with the map and draw walls with transparent insides outside of what I’ve already started:

Here is how I am selecting/defining my wall:

You’ll notice I took the original tileset and just edited out all the black from it in this picture. It’s the same tileset with just the transparency there.

Edit: If you want the actual files, I’ve uploaded a .zip file here:

I think you have your wall the wrong way around. The wall tiles are drawn in such a way that the black part is outside the room, not inside. That’s why I said you can fill your map with black and then use the erase mode to make the rooms. After that, you’d just fill the rooms with whatever floor tile you want.

So, it is the same wall for all rooms. The way you have set up “KitchenWall” makes no sense, since it places kitchen floor tiles outside of the wall.

The KitchenWall was just an experiment. You’re absolutely right, it doesn’t work at all. It was “Wall Transparent” that I was hoping you’d look at.

Perhaps I’m not quite understanding something here; I didn’t need to have an all black part oustide the room and then use the erase tool… I could have an all transparent background, then use the terrain brush to “paint” my room. However, since it used black inside the room, I wanted something transparent so I could layer it. My idea was going to be to have my tiled floor being the first layer, then the walls being a layer on top of it.This way, the walls would sit on top of the floor tiles, and with a transparent (no black) filler being associated with my wall terrain, you would see the floor tiles.

This is why I edited the original tileset. Am I making sense? - I’m not always good at explaining things!

Anyways, now I’m trying to get Wall Transparent to work!

I think this is where you area going wrong. The original tileset was not meant to be used that way. The black part is supposed to be outside of the room, not inside of it. It does not really help to make it transparent, because it will not be connecting right to the other tiles, at least not like in the map you showed in your first post.

If the outside of the wall works for you as an inside, as long as it is made transparent, then by all means go for it. I do not understand what problem you have with the “WallTransparent” terrain. It works exactly the same way as the setup I showed you above.

I think I found the problem. I believe it was a bug or something with the Layers. I deleted all my layers and found that it was working afterwords when I created a new layer. Thank you very much!

1 Like