Terrain Fill Mode

Hello, I need help with the “terrain fill mode” tool.
I am following these tutorials:
1 - doc. mapeditor.org/fr/latest/manual/using-the-terrain-tool/
2 - AET 304: Using the Terrain Brush in Tiled - YouTube
I also saw other tutorials and they are all the same.

In my tiled there is no option "add terrain type.

My biggest problem is that my Tiled selects only one square and not a set of squares when I put it on the map.

Ex: here is how it looks in the youtube tutorial:

Here’s how it looks on my Tiled: imgur.com/a/D9y1JXF

Why is there only one selection on my Tiled? I need it to be bigger, to select the same as the video, but only one square appears

Another problem:
In my Tiled there is no way to make the selection as shown in the tutorials.
Ex: imgur.com/a/JtNFUm5

I can’t drag this blue tip in any way.

The only way to do something like the tutorials is this: imgur.com/a/CpeCkWd

But it doesn’t work, it selects random squares and doesn’t follow the path I’m creating.

I’ve tried to select several types of combinations between the sprites connection and nothing …

As the guy does from 4:45 this video: www.youtube.com/watch?v=WEtml6DuwqQ

I need to make automatic maps of caves, but I’m not getting it.

With this option it would be easier than placing square by square D:
Help please

Why did you put random spaces in your URLs and make them unclickable ):

Tiled 1.5 changed the way terrains work so it’s a little different from old tutorials.

  1. Of you want to follow older tutorials, you’ll probably want to use corner terrains, not mixed terrains like you seem to be. Different terrain types behave differently. Pre-1.5 terrains were all corner terrains.
  2. Instead of tilesets just having a bunch of terrains, they now have terrain sets, and each of these sets contains terrains. The Add Terrain button appears when you’ve got a terrain set.
  3. You can hold Ctrl to make the tool paint a slightly larger area. This is inverse from how the old tool worked, where you’d hold Ctrl (or Alt? I forgot) to paint a smaller area (modifying one corner at a time) instead.
  4. If you’re having trouble drawing a terrain, it’s almost always because Tiled can’t find any valid transitions between what you want to draw and the tiles already in place. For example, if your grass tiles are labelled with a grass terrain and have no transitions to transparency, and you’re trying to draw on grass with a dirt terrain that can only transition to transparency and not grass, Tiled can’t make that work. You’d need to draw the dirt terrain on a separate layer, where it can transition to transparency.

Bcz new users cant put more than 2 links
U can enter, just copy past and just join the spaces that I separated

1 - I tried all types like corner, dont work :confused:

2 - I will try with a terrain set

3 - Tried control button, dont work :confused:

4 - The layer was filled with grass before, the tutorial said this

We figured this out on Discord. The problem was two-fold:
First, OP was trying to use the Tile Stamp tool in Terrain Fill Mode, which randomizes terrain instead of painting the specific terrain they wanted. The tool to use is the Terrain Brush.
Second, when they switched to the Terrain Brush, it wasn’t working because they didn’t have a Terrain selected. They correctly selected the Terrain Set they wanted to use, but the Terrains view was collapsed so they didn’t see that they also needed to select a Terrain.