Grid lines not displaying correctly

I am not sure if this is an actual bug with version 0.18.1. I just recently installed 0.18.1. I was previously using version 0.17.0. The grid outlines do not seem to be displaying correctly.

ver. 0.18.1

ver. 0.17.0

Hmm, that’s probably due to the switch from QGLWidget to QOpenGLWidget in Tiled 0.18. This avoided the additional dependency on QtOpenGL and solved at least one bug, mentioned in the changelog as “Fixed OpenGL rendering mode when application is scaled (HiDpi screens)”.

But, I didn’t realize it could affect the grid like that. It’s certainly rendering fine for me on Linux. I’ll give it a try on Windows soon, but I’m not sure what I could do about it.

The easiest fix with the new Tiled version would be to turn off hardware accelerated rendering in the Preferences. It’s actually off by default since it brings no advantages over CPU rendering in most scenarios.

Turning off hardware acceleration corrected the problem. I didn’t have it turned on in version 0.17 so i’m not sure how it got turned on in the new version since I installed it earlier today. Anyway thanks for the suggestion!

I tried it on Windows too now, but I can’t reproduce this issue. Do you think there may be anything special about your setup or configuration?

There very well could be. I have upgraded my graphics card in the last couple of months. I removed version .018.1 and installed 0.17 and everything works fine. I do notice in version .017 when turning on hardware acceleration the grid lines get darker and easier to see. This is the same for 0.18.1 except the lines get messed up. For what I am doing I can live with hardware acceleration turned off.

Yeah, a different paint engine is used in OpenGL mode. That happens entirely on the Qt side, hence there is probably little I can do in Tiled to fix the rendering of the grid lines. The appearance in non-OpenGL mode is the intended one.