Tiled 0.18.1 released

Today I’ve released Tiled 0.18.1, a recommended upgrade since it fixes some crashes and several other issues. It also makes a host of improvements to the GameMaker 1.4 export.

Thanks to everybody who contributed to this release with bug reports, suggestions or patches!

A note for Windows users upgrading from previous versions using the installer: Please first uninstall Tiled manually and then reinstall using the installer. Due to fixing the installer to work properly system-wide, it will fail to upgrade versions before 0.18.1 and leave behind a broken Tiled.


  • Fixed terrain brush for isometric staggered maps (#427, by Clyde)
  • Fixed crash when resizing map causes objects to get removed
  • Fixed crash when duplicating an object layer
  • Fixed position of image layer after Resize or Offset Map (#1418)
  • Fixed the quality of the minimap on HiDpi displays
  • Fixed Alt-drag behavior to not override resize handles (#1425)
  • When adding a new layer, insert it above the current one
  • GmxPlugin: Fixed positioning for non-tile objects and support scaling (#1426)
  • GmxPlugin: Export tile objects without a type as tiles
  • GmxPlugin: Support horizontal and vertical flipping
  • Windows: Fixed encoding problems with command-line output (#1381)
  • Windows: Fixed the architecture of shipped MSVC DLLs (#1338)
  • Updated Chinese translation (#1432, by Clyde)

Support Tiled Development

These fixes and improvements were possible thanks to your support through Patreon and on itch.io! If you are not supporting me yet, please chip in to ensure they can keep coming! Thanks! :heart:

Having a problem with the Windows x64 installer. It says 18.1, but when I install it and look at the “about” box, it’s version 18.0.

It then asks if I’d like to update, and it re-downloads the same installer.

I ran into the same problem in testing, but unfortunately I have no idea what is causing it. What worked for me was to uninstall and re-install Tiled. I hoped the issue would be rather rare, because I don’t know where to start to fix it.

It seems the MSI will in some scenarios think that it can re-use existing files, even though they are not actually the same. :frowning:

Hmm, this appears to be a problem affecting everyone and it’s related to marking the installer explicitly as “per-machine” in change c717d5a. It even results in two “Tiled” entries in “Programs and Features” and two desktop icons (the old one from the user’s folder and the new one at the system level).

I have no idea why MSI is silently messing up this upgrade after changing this setting, and I also don’t know the best way to proceed. Actually I think the “per-machine” setting should have been there from the start, since the installation was always meant to be performed in that mode. But to fix the upgrade, I’d need to release a new installer with this option reverted again. :confused:

Alright, I did an attempt at fixing this by reverting the InstallScope='perMachine' addition, but while testing the release of a with this fix, I could not get the upgrade to work properly from either a clean installed 0.18.1 or a 0.18.0 that had already attempted the upgrade to 0.18.1. The only case it would fix would be a 0.18.0 or earlier installation that would try its first upgrade to

Since I think the per-machine flag should should be there, I’ve added a message to the update popup that instructs the user to uninstall Tiled and re-install it manually.

I’m quite fed up with installers, having had numerous issues with NSIS and now with MSI, that I’m really thinking about alternatives again and maybe would go with plain zip file distribution, as long as there would be some auto-update mechanism.