How can I make the terrain tool/brush work properly?

I have been tiling coastlines manually for going on 6 hours now. I keep trying to set up the tile brush, followed tutorials on youtube, online, and other forums, but it doesn’t seem to work.
This pic is the current configuration, the one most like the way the tutorials showed. I also tried a near endless amount of other configurations.

I set it up, click ok, go to Terrain tab, select it (Grass), go to paint em on, and all it does it places the last tile I used on the Tilesets tab. I tried using the Terrain brush, then when I click nothing happens, no tile gets placed.

I made a new map (for troubleshooting), I currently have a “sea” layer and a “grass” layer on top of it.

Please tell me what I am doing wrong.

It looks like your tiles are cut too small. If you cut them twice as big, the terrain tool would be able to work with them. Of course, that means you’ll have to increase the tile size of your map as well.

If you need different tile sizes for different layers (like 32x32 for the terrain layer but 16x16 elsewhere), you’re currently out of luck with Tiled. I would like to add support for this later though and it’s tracked by the following issue: