How do I export as an image with no whitespace around tiles?

I would like to export my 18x1 tilemap with no whitespace in the final image. Right now, my canvas is locked to 16 tile increments in the x and y direction. When I used the Map>Resize Map feature, my inputs to shrink my canvas to 18x1 is ignored and it stays at the 32x16 dimensions that it autosized to originally.

Is your map set to infinite? If so, please try disabling this in the map properties and then resize the map to 18x1 and then export as image.

I’ll try to improve the behavior for infinite maps when exporting them as image.

Oh that might be the problem. Let me try that.

Worked like a charm. Thank you for the quick reply! I switched from my other tile editing software to this since I had heard about how active this project is.

1 Like

Glad to hear that! Like I said, I will look into improving the behavior so that switching off the infinite option should not be necessary.

What other tile editing software were you using before?

This project has remained so active thanks to the support I receive from many people on Patreon and people paying for Tiled on This allows me to keep working two days/week on Tiled despite now having a family with three kids, which has consumed all my spare time.

You are going to laugh… but I was using the tilemap plugin for Unity… What a joke. I am just building out the base maps in Tiled and exporting it to Unity right now as a backdrop. It is 100% worth the extra step. I have used tmx parsers in the past for LibGDX games, and I think I am going to have to roll my own for Unity too. Not too worried about it. I will cross that bridge when I get there. Tiled rocks! I bought it on, but I will go add a pledge on Patreon right now :slight_smile:

1 Like

I use the program paint edit the image size color and look before I put it through tiled.

I use 100 x 100 pixels sizes for each individual image file. Works good for me