Terrain Tool works only for first layer?


I’ve created some terrain brushes folowing this tutorial:


It worked fine, but when I create a second tile layer, the brushes dodn’t work!

It is drawn a single tile!

How to make the terrain tool work on a second layer?


I think you might have forgotten about this paragraph, which solved the same problem for the first layer:

Switch from the Tilesets to the Terrains window. You should see the 4 terrain types represented in a list. Click on the sand terrain and start painting. You may immediately notice that nothing special is happening. This is because there are no other tiles on the map yet so the terrain tool doesn’t really know how to help (because we have no transitions to “nothing” in our tileset). Assuming we’re out to create a desert map, it’s better to start by filling your entire map with sand. Just switch back to the Tilesets window for a moment, select the sand tile and then use the Fill tool.

Since your second layer is empty, and the tiles have no transitions to “nothing”, the terrain tool can’t help you. Fortunately, you actually don’t need a second ground layer, right?