Tiled 1.0.2 or 1.0.1 won't launch on windows Vista


#1

Hello, as you read the title I can’t even launch Tiled…

I get the following error messages:

And:

I tried to reinstall Tiled multiple times, but this still doesn’t work :confused:

Before having the 1.0.2 version, I had an older version (unfortunately I don’t remember which one) and it seemed to work fine, but since I can’t download back the older versions, I’m stuck…

I don’t get what is the problem, is this fixable?

Anyway, have a good day :slight_smile:


(Thorbjørn Lindeijer) #2

The install should work, as long as you first manually uninstall all versions of Tiled on your system. See:


#3

I just tried again, I uninstalled Tiled with the Windows program manager (I don’t know how it’s called in english, but I did with windows and not with the Tiled setup), I installed Tiled 1.0.2 again and it still shows me the same error message :confused:

I also tried to destroy the Tiled folders directly in “Program Files” and “Program Files (x86)” and install it again, it still doesn’t work, same error window as before…


(Thorbjørn Lindeijer) #4

I only know that uninstalling only one version of Tiled if you had two installed is not enough. That’s why I emphasized that all versions need to be uninstalled first.

If the installer still fails to add all the right files for Tiled to run, you can alternatively use the .zip downloads on itch.io (the snapshot builds). The recommended way to install those is via the itch.io app, which will keep your snapshot up to date when I release new versions.


(Thorbjørn Lindeijer) #5

Btw, you can download older versions from here: https://github.com/bjorn/tiled/releases


#6

I think I’ll just download old versions and see which one works, thank you :slight_smile:


(Thorbjørn Lindeijer) #7

Just note that it’s a problem with the installer, not with the version. The installer changed in Tiled 0.18.1. If installing 0.18.0 doesn’t work either anymore (which could be the case, due to installing 0.18.1 or newer), any older version will likely not work either.

I’m slowly considering to drop the whole installer business…


#8

Oh, I see, sorry if I misused the term “version” here.

I can install and launch the 0.18.2 without any problems, but I’d still like to have 1.0.2, I’ll try to install it manually.


#9

Even if I download the 1.0.2 snapshot in a .zip form without the installer, I still have the same error message… I think it comes from my computer :confused: