0.16.0 crashes when maximizing the window

I just updated to 0.16.0 and whenever I try to maximize the window, it closes out with Windows crash message saying “Tiled has stopped working”.

I tried removing the installation and starting fresh, even tried 32bit and 64bit separately, but it didn’t seem to help. Resizing the window to fill the screen doesn’t make it crash, only maximizing.

Is this a known problem or is there a potential fix for it?

You’re probably running into this issue:

If so, it’ll be fixed once Qt 5.6.1 is out and Tiled releases are built against it. In the meantime, you should either avoid maximizing the window or close the Maps view (which you probably have open?).

Thank you for the response. I didn’t see that on GitHub, but it looks like that’s exactly what’s happening.

Yes, I had the Maps open. Closing Maps did make it maximize properly. Once I closed Maps and maximized, I was able to open Maps again and it seems to be working properly, even after closing and opening again.

Thanks for helping me get around that annoyance.