Tiled crash when I put a tile on my map

Hello there!

I have a crash sometimes when I put a tile on my map. The software stops without any error, after a very short time when my cursor indicates a loading. When I open Tiled after the crash, saved changes have been taken over if I open the map again, but unsaved changes are lost. Furthermore, Tiled opens the map that was open during the previous opening.

  • At first, I thought it was a bug caused by using Dropbox to store my Tiled folder. Then I moved my folder out of Dropbox. :x:
  • I tried to reinstall the Windows version. :x:
  • I tried to move my folder from my SSD to my HDD. :x:
  • I tried to enable/disable the secure file writing. :x:
  • I tried to enable/disable the OpenGL hardware acceleration. :x:
  • I thought it was an error in my automapping rules. :x:

I admit I run out of ideas to solve this problem. Maybe it’s a known issue?

I have the 1.3.3 version of Tiled (but the bug is here since more than 1 year).
I use Git to save my folder on a repository.
OS: Windows 10 64bits. 16Go RAM.

Sorry for the second post, but I found something on my windows event observer:

It seems like there are some application errors (1000) & Windows error reporting (1001).
And it seems like Qt5Core.dll & Tiled.dll are involved.

I searched in my history and it was the same errors in the past that caused the previous crashes.

Sorry for the issue! :sweat_smile:

I was on my windows history and I found that:

maybe that StackHash will help?

Does the below answer from Microsoft Support help with resolving this crash?


Unfortunately not because I have Windows 10 64 Bits. When I add an exception for Tiled, Windows tell me I can’t add exception for 64 bits files.