Autotile rules question

I’ve set up a rules file that works most of the time, but there are some rules that never take effect and I’m lost as to why. In the attached image, the rule pointed out never happens and I don’t know why or how to fix it. I assume it is a conflict with another rule but I’m not sure why. I have tried it with MatchInOrder being on and off, with no effect.

Are you showing inputs, outputs, or both here?

Do these two rules have the same inputs? If so, the second one probably always overwriting any output from the first.

It’s also possible other rules match that same tile for other reasons and overwrite the output of the first rule. Have you tried running Automapping with only this rule?

These are the input layers. It not like there are being replaced with incorrect tiles, it’s that nothing is happening? The map has several tiles that I pointed to and nothing to the right, but they are never being replaced with the output tile. Does the system see a match and then stop looking? I thought MatchInOrder was suppose to stop that.

Even if that was the case, I should see some replacement from the other rules. But in this tiles case I see nothing. I do see our tiles being replaced, so I know it’s generally working.

All rules are always checked, and if anything, MatchInOrder is more likely to prevent other rules from applying, because it may modify the layer before those rules get a chance.

Without seeing your full rules and your test inputs, it’s hard to know what’s wrong, sorry.
One thing to check is that the test scenario for that rule isn’t somehow on a different layer.

Here is the situation where its not being replaced.

Do you definitely have an output set for that rule? It’s possible the rule is matching, but just not outputting anything.

If that’s not it, make sure that tile isn’t possibly being output by some other rule. As I mentioned earlier, a good way to test this rule specifically is to run Automapping with only that rule and no others.

I see what the issue is. I have two tiles are differ by only 1px and my rules used the wrong one.


Yes, that is what is was, I cleaned up my rules to use the right tile and everything work.