Can't find out how to import multiple (already existing) tilesets


#1

Hi,

So I am new to this tile map editor. I am using multiple tilesets to create a map, however after creating them I can’t find out a fast way to open already existing tilesets (which I already created and are located in a map).

Everytime I click away a tileset I need to create a new tileset from a file and overwrite the tileset .tmx located in the tileset folder.

I have tried the following:
-Open using explorer (trough Windows just double click)
-Open using top menu bar: Map -> add external tileset --> select my tilesets (getting alot of error messages there).
-Also used file -> open -> select tilesets, gives error messages.
-Also tried dragging tilesets from explorer to the tileset panel.

I presume there has to be an option for this, I just can’t find it.

Thanks in advance!

-Dustin


(魔大农) #2

In the tilesets panel there is a button to Export Tileset As after which you should be able to add it to other maps as an external tileset.

What kind of error message(s) are you seeing?

Also, welcome to the forums! :confetti_ball: :slightly_smiling_face:


#3

The export button is greyed out on my computer

The error does not have a message, just an error icon.

errorimage

I just made the map importing one tileset at a time (had to import 10, so lots of clicks). The tilesets are still there when I re-open the map, so all is well. Just takes some time to import multiple tilesets since there is no bulk open function as I’m aware of.

Thanks for the reply, the editor works well and I created an awesome map. Just needed some time getting used to it and find where some functions are and how they work.


(Thorbjørn Lindeijer) #4

Since Tiled 1.0, external tilesets are the default, so he’s already using external tilesets (hence also the overwriting when creating a new tileset).

The main question I have, is why do none of the methods of opening those existing external tilesets work? All of them are valid ways of opening the tilesets for use on the map. It doesn’t help that the error message box is empty…

@jetspiking Are you maybe trying to open the image files as a tileset? When you select or open your tilesets, you need to choose the .tsx files.


#5

Thanks for your reply!

I tried to open the image files using the import button. Later I found out that it had to be .tmx files. When you created the tilesets one by one its all good. However it could’ve been alot better if you could create multiple .tmx files from multiple tilesets in one step, instead of having to select them and create them 1 by one from the .png’s. My tilesets all had the same settings considering width, height etc.

I was testing with little over 15 tilesets, so when you accidently click them away thinking you can re-open them it’s some work to re-create them 1 by one. (this was only the case if I had not used the tileset, otherwise it could be re-opened if I remember correctly).


(Thorbjørn Lindeijer) #6

Well, at least the settings are persistent so you just need to click through the saving dialog, right? But sure, there is still room for improvement. When I get around to adding support for projects, I imagine the files could be saved automatically in standard locations, further reducing the amount of clicks. Thanks for your feedback!

At least when you did in the end save each .tsx file, it is just one step to add them all to your map.