Corona simulator does not show flaming torch animation, which shows clearly in Tiled map editor


(Shahjada Ahmed) #1

Hi,
Can someone please help me with an issue I am having :frowning: . I am not able to see the animation from Tiled map editor after I run build in corona simulator.

Here is what I am using :

  • Dusk Engine
  • Tiled map editor
  • Corona sdk
  • Xcode to build in iphone 7

Here is a description of the problem :

  • I created fire animation using a sprite sheet in Tiled map editor
  • Dragged the fire animation in one of the layers in Tiled map editor
  • Fire animation clearly shows in my Tiled map editor
  • The animation does not show up in corona simulator
  • The animation does not show up on ios after building using xcode in iphone 7
  • Tile map properties I have added anim:enabled true

Am I missing something? I was expecting the fire animation from the tile layer to show up in corona simulator too :frowning: Some assistance would be much appreciated and also a step by step guide if possible. Thanks.


(Thorbjørn Lindeijer) #2

Please understand that this is the Tiled forum, and that Tiled itself is independent of any particular framework like Corona. You’ll have a much higher chance of finding a solution to your problem if you ask in the Corona community, or in this particular case, maybe try asking the Dusk Engine developer.

That said, please keep us updated if you find a solution!


(Shahjada Ahmed) #3

Thanks a million for the response. Could you please let me know the custom property which I need to put in the tile layer section to see the animated tile? I did put anim:enabled true, but not sure if there are any others property I should be adding. Thanks.


(Thorbjørn Lindeijer) #4

You’re asking the wrong person. This is a question for people who know Dusk Engine, since you’re talking about a custom property for that engine. Like I said, you are more likely to find an answer if you ask in the Corona community or open an issue on the Dusk Engine repository.


(Shahjada Ahmed) #5

Solution to the animation problem I was facing with the flaming torch. I switched from Dusk to Berry Engine. I followed the tutorial link from Idurniat : https://github.com/ldurniat/Berry/wiki/Adding-Life-Through-Animation and it is working perfectly now! I am able to see the flaming torch animation without any issues. The torch was treated as an object which was given animation property from corona code and it worked flawlessly. If anyone wants to have a look at the code, please ping me in this thread or personally. Thanks a million, love you all who helped me out.