Crashing on startup, M1 Macbook Ventura 13.4

This was working fine for me the other day, but today suddenly started crashing on startup. Tried a fresh install, no luck. I had been editing a custom script before opening, but undid the changes and also tried removing the script from the extensions folder but no luck there. The first crash was after opening a supertiled2unity prefab directly from my unity project.

Usually when an application crashes on macOS there is a crash dialog popping up, which could contain useful information about what triggers the crash. Do you see such a dialog?

Also, a fresh install does not reset your session or configuration. You could try deleting your .tiled-session file (stored alongside the project file) or resetting the settings by deleting ~/Library/Preferences/org.mapeditor.Tiled.plist. However, please see if you can help find the cause of the crash before doing these steps (or, backup the files instead of deleting them, in case something in them can help reproduce the crash).

Hey, I tried both of these. It briefly solved the issue but it returned the next time I tried to open a file. I’m using SuperTiled2Unity as well, not sure if that could be causing issues.

Process:               Tiled [4989]
Path:                  /Applications/
Identifier:            org.mapeditor.Tiled
Version:               1.10.2 (1.10.2)
Code Type:             ARM-64 (Native)
Parent Process:        launchd [1]
User ID:               501

Date/Time:             2024-05-07 13:40:43.3410 -0400
OS Version:            macOS 13.4 (22F66)
Report Version:        12
Anonymous UUID:        24202876-A2C1-8D38-3BE5-D43CE9B0190C

Time Awake Since Boot: 13000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue:

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000769414180a80
Exception Codes:       0x0000000000000001, 0x0000769414180a80

Termination Reason:    Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process:   exc handler [4989]

VM Region Info: 0x769414180a80 is not in any region.  Bytes after previous region: 24824711219841  
      REGION TYPE                    START - END         [ VSIZE] PRT/MAX SHRMOD  REGION DETAIL
      MALLOC_NANO (reserved)   600018000000-600020000000 [128.0M] rw-/rwx SM=NUL  ...(unallocated)

Thread 0 Crashed::  Dispatch queue:
0   QtWidgets                     	       0x1065d6dec 0x106498000 + 1306092
1   QtWidgets                     	       0x1065d6c98 0x106498000 + 1305752
2   QtWidgets                     	       0x1065deea4 0x106498000 + 1339044
3   QtWidgets                     	       0x106614d50 0x106498000 + 1559888
4   QtWidgets                     	       0x106614668 0x106498000 + 1558120
5   QtWidgets                     	       0x1064d2290 QLayoutPrivate::doResize() + 224
6   QtWidgets                     	       0x1064d28d8 QLayout::activate() + 1224
7   QtWidgets                     	       0x1064ee780 QWidgetPrivate::setVisible(bool) + 512
8   QtWidgets                     	       0x1064d6bf0 QStackedLayout::setCurrentIndex(int) + 384
9   libtilededitor.dylib          	       0x104d3add8 Tiled::DocumentManager::currentIndexChanged() + 536
10  QtCore                        	       0x105ffd21c 0x105f48000 + 741916
11  QtWidgets                     	       0x1066707a4 QTabBar::setCurrentIndex(int) + 408
12  QtWidgets                     	       0x106670444 QTabBar::insertTab(int, QIcon const&, QString const&) + 592
13  QtWidgets                     	       0x1066701c0 QTabBar::insertTab(int, QString const&) + 60
14  libtilededitor.dylib          	       0x104d3d818 Tiled::DocumentManager::insertDocument(int, QSharedPointer<Tiled::Document> const&) + 796
15  libtilededitor.dylib          	       0x104d3cccc Tiled::DocumentManager::addDocument(QSharedPointer<Tiled::Document> const&) + 28
16  libtilededitor.dylib          	       0x104da84d0 Tiled::MainWindow::openFile(QString const&, Tiled::FileFormat*) + 372
17  libtilededitor.dylib          	       0x104da92c0 Tiled::MainWindow::restoreSession() + 120
18  libtilededitor.dylib          	       0x104da8d6c Tiled::MainWindow::initializeSession() + 156
19  Tiled                         	       0x1047fbb98 main + 5820
20  dyld                          	       0x18baa3f28 start + 2236

That does look like a problem in Tiled. It’s crashing while trying to create a tab for a map that was open in your session.

Would it be possible to share your project, session and map / tilesets? In case you can’t share them on the forum, you could email them or send me a link? That way I could try to reproduce the problem, since from the stack trace I can’t make out what’s going wrong.

Also, it could help if you would test whether this problem still occurs in the current development version. If you log in to GitHub, you can visit Python plugin: Added forgotten PyConfig_Clear call · mapeditor/tiled@288cd98 · GitHub to find the latest build for macOS under “Artifacts”, take the “” and let me know whether that version is also crashing (and if so, post the report as done above).