Created a terrain but it's not showing up in the terrain tab

I created a terrain, but it’s not showing up in the terrain window so I can’t use it on my map.

Hmm, can you provide a few more steps to reproduce your issue? I’ve tried the following:

  • Opened example map isometric_grass_and_water.tmx
  • Clicked the “Edit Tileset” button below the tileset view
  • Clicked the “+” button for adding a new terrain type
  • Switched back to the map
  • In the “Terrains” view, I can see the “New Terrain” I just added in the tileset editor (this is the step you’re reporting as failing).

Yes! I did all of that but it’s not in the terrain tab.

So exactly how do I fix the bug? I can’t make my maps without it because the path won’t be the same if I do it block by block.

Well, I can’t reproduce your issue, so either there is something different about our versions of Tiled or something different about the steps we’re taking. When we find out what it is, we can look into fixing the problem.

What version of Tiled are you using? If it is Tiled 1.0, did you try using Tiled 0.18 to see if there was a regression? You can find older releases on GitHub.

The latest one, 1.0.1

I’m getting this too. Just updated to v.1.0.1, did all steps exactly as above… no terrain in the terrain tab.

I found a workaround, until this gets fixed!

If you hit ‘embed tileset’, the terrain magically shows up! … You’ll need to deal with two identical tilesets, but at least the terrain tool starts working…?

Ok but how? I pressed the button but it’s still not there

Nvm it worked

I’ve started the following change to address this issue:

In general, you can work it around in the current version by manually adding the external tileset to the map, using Map -> Add External Tileset…

1 Like

A fix for this is now released as part of Tiled 1.0.2.