Custom "name" property doesn't work in CSV export

Hello! I’m new to Tiled.
I searched the user manual for export formats and found that: if a tile has a custom property called “name”, it will be written out by the “name” porperty’s value in csv.file.
That’s what I did

The CSV export:


I’ve tried to set the “name” property type to int and string, and got the same result. I don’t know what went wrong. Any help would be much appreciated!

It works as documented for me with name being either a string or an int, I’m using Tiled 1.3.2. What version of Tiled are you using? Perhaps this feature regressed in an update.

Would you mind sharing your tileset and map files (just the TSX and TMX, the image is optional)? I’d love to see if I can reproduce this problem.

1 Like

Thanks for reply! I am using 1.3.3. Here are screenshots of TMX and TSX

Ah, I meant the files, so I could load them myself xP

The CSV you posted earlier, is it copy+pasted from this map file by any chance? The CSV name substitution thing only applies to the CSV export, where the map is exported as a CSV file per layer, NOT to the CSV encoding mode when exporting as a TMX. Because the TMX format is able to include additional data about the tiles, the name substitution is unnecessary and thus not done.

1 Like