Delete custom property

Version 1.9.0
Tiled is shoot down unexpectedly after remove any object Custom Property by ‘Minus’ button.

1 Like

I can’t reproduce this crash. Creating a custom string property on a rectangle object (and on a Tile Layer, for good measure) and then deleting it with the “-” button worked as expected, no crash.
What property types are the properties that crash when deleted? Are templates or Custom Property Types involved in this?

If this affects all properties for you, no matter the type and even if they’re created as just regular custom properties (not inherited, not a custom type), then try redownloading and reinstalling Tiled, it’s possible something went wrong during installation.

simple text and custom property

That’s not just a simple Object in your screenshot, it has a Class, “Text”. Are these “text” and “stick” properties coming from the Class, or were they added to the Object manually?

I just tried repeating this example - made a Text object, gave it a class, then I tried to set and delete both a class property and a new property, no crash. So, I’d consider reinstalling Tiled just in case it was a problem with the install rather than with Tiled.

On an unrelated note, why are you duplicating properties of the Text object in custom properties? Your properties seem to largely duplicate the Text and Alignment properties that the Text Objects already have.

This layout was created in previous version of Tiled (1.8.6) and ‘Class’ called ‘Type’.
Custom property was added manually.

in all previous versions everything was normally

Have you tried reinstalling Tiled like I suggested? In my install, everything still works normally to, so this bug doesn’t appear to be a 1.9-wide problem.

Oh, I forgot to ask: What OS is this on? Maybe it affects some OSes but not others. I tested on Windows 10 x64 and could not reproduce the issue.

Windows 10 x64
I have uninstall and install Tiled. Result is the same.
the problem also arose in the new project, project was saved in json format

It’s an unfortunate regression related to the support for custom classes. When you have not created a project, Tiled will crash when removing a custom property. So, your workarounds for now are to either downgrade to 1.8.6 or to create a project.

I’ve submitted a fix and plan to release a Tiled 1.9.1 soon.


This bug fixed in version 1.9.1

1 Like