How to get latest build on Windows (How to compile)

NOTE: It’s ridiculous that I’m only allowed two links. So I guess y’all will just have to reference this imgur album:

Hey there!

I’ve never worked with Qt before, so I basically am going in blind here. I downloaded the installer with the link provided and made sure to install the Qt MinGW version as specified in the Readme.

So now I have a folder with a bunch of Qt stuff in it ( IMAGE ONE )

However, the readme doesn’t state what to do next.

I then went to open Tiled project in QtCreator and pressed the green run button and got this ( IMAGE TWO). Had no idea what it was asking for, so I went on to try something else.

I then went to try the hammer button (build) and got an infinity worth of errors ( IMAGE THREE )

I’ve also tried running the qmake command in both the Qt directory and tiled directory-- cannot find specified command.

I believe that a more in-depth guide to how to compile Tiled on windows is necessary, because I have a game in development that very much would love to make use of the new scripting features, but I cannot test any scripts until I have a 1.3 build which seems to be of an unknown release date.

At the very least if someone could just provide me a 1.3 beta build, I’d be very much appreciative.

Thank you very much.

Hey @ktar5, welcome to the Tiled forums!

The default number of images you can share as a new user is 1 by default, but I had upped that to 2 already. Now I’ve increased it to 3. :slight_smile:

Judging by your first screenshot, you may have installed MinGW itself, but you did not select an actual MinGW version of Qt.

Did you find this wiki page? I think it’s the most in-depth one. If you run into any problems still, please let us know.

New develop snapshots are released on average about every two weeks. They are the “snapshot” builds available on You can read the devlog about what’s new in each new snapshot build.

Awesome! Thank you very much!