Installation issues


I am using Windows 7, 64bits version. I first tried to install Tiled with the latest Windows installer (64bits). When tried to lauch the software I had the 0xc000007b error. I did a check disk but it said it was clean. After that I tried to install (executing as admin) the 32bits version and this time nothing seems to happen except that there is something loading, at this time the folder windows is unusable (can’t close normally or navigate to another folder) and I can only close it by using the task manager. When I look to the processus, i see that the installer is running and doesn’t appear in the applications tab (I can’t delete the installer exe by the way).

EDIT : I can’t even stop the processus in the task manager, I have to close at least my user session to abort it.

Thank you for your help.

(sorry if there’s bad english, I’m not a native speaker)

Hmm, I assume your first problem is the same as this one:

But in that case the 32-bit Tiled at least worked properly.

I have currently no idea what could be causing these issues, but I’m looking into a new installer solution, probably replacing the NSIS installer with an MSI installer. That will hopefully be better supported on newer versions of Windows.

I tried with the latest release, I have the same problem with the 2 versions (64 and 32bit). The setup exe doesn’t launch properly. (same issue I had with the older 32bit versions).

I was assuming you meant the latest release before already. Do you mean that you tried it with the daily builds? Anyway they are generated the same way so I wouldn’t expect a difference for now. Hopefully I’ll get a new installer solution working tomorrow.

Yes, that’s it. I tried with today’s release.

Yesterday I finished work on an MSI installer based on WiX. Can you please try whether you can install Tiled using that installer without issues? It is available at

Direct links to current latest installers for 32-bit and 64-bit versions:

Unfortunately not working. In both version (32-bit and 64-bit) the installation process stop at the “removing applications” part, I can’t even close it (I can click on cancel, the dialog boxe opens but doesn’t seem to work). I also need to reboot my PC to uninstall it after that.

Can you please make some screenshots? This does not make any sense to me. There should not be a “removing applications” part in the installer, nor should there be any need for a reboot step for either install or uninstall.

the screenshot :

And when I close the installer (with the task manager), the processus doesn’t stop. therefore when I try to uninstall it says the installer is already launched. And the only way I found to close it was to reboot my computer (manualy with the power button otherwise it blocks on the shutting down screen of windows).

Thanks for the screenshot! I’ll have to investigate this. Could you try if it helps to run the installer as administrator? Might be available in the context menu when right-clicking the msi file, but I read this got removed,

No I can’t run as administrator. :confused:
Now I can’t even launch the installer. It told me it is already installed, despite the fact that i deleted the files in Program Files (and there’s nothing in AppData). Maybe because I shuted down during the installation process…
And when I right click and do repair or uninstall a Windows error appears telling me there is no software to uninstall.

Yay !!! >_<

I’ve made some improvements to the installer, so please check whether the latest version works for you.

@yomosaure Please can you let me know whether recent installers still have issues on your system?

I had putted it on hold for a while. And when I tried clicking on the icon of tiled today, it worked !
The installation seems to have succeeded althought the installer seemed to stop working.

Alright, it’s strange that it seemed to stop working and currently I still have no idea what may be causing that, but if it anyway worked in the end that’s great!