HELP! Tiled broke

Tiled 64 bit gets an error code every time i try to open it but i downloaded the 32 bit ones opened fine but doesnt work for 64 bit operating system how can i fix the 64 bit download

What error pops up for the 64 bit version and what doesn’t work about the 32 bit version?

Also, since you say it broke, was there a version you used before that did work and since when is it no longer working?

I had a similar issue (installed Win32 x64 on 28/12/2016:

tiled.exe - Application Error

The application was unable to start correctly (0xc000007b). Click OK to close th
e application.



Using depends.exe I can see that MSVCR120.DLL and MSVCP120.DLL have been installed to
C:\Program Files\Tiled, and are x86 instead of x64 as they should be. Replacing them with the X64 versions allows Tiled to run as expected.


Using the MSI installer? That’s very strange since it’s supposed to be picking up the right files. Thanks for noticing in any case, I’ll have to check this!

So, I was copying those files from C:\Windows\SysWOW64 for the 64-bit build and from C:\Windows\System32 for the 32-bit build. However, it seems that at least on my Windows installation, the 64-bit DLL sits in C:\Windows\System32 and the 32-bit DLL sits in C:\Windows\SysWOW64. The naming of these directories has utterly confused me and resulted in shipping the wrong DLLs version along with Tiled, at least since the introduction of the MSI installer (not sure if it affected the NSIS one)…

Now I realized that WOW64 means “Windows 32-bit on Windows 64-bit”, so the SysWOW64 directory then logically contains the 32-bit DLLs. It does not explain why the folder containing the 64-bit DLLs is called “System32”, but I guess that can be attributed to backwards compatibility and this folder containing both 32-bit and 64-bit DLLs for now.

The fix was trivial now:

All quite correct. It was a recent install of Win7. As to the system directory naming convention, all I can say is “Windows Madness!”. The Windows developers were constrained by existing install apps. Full disclosure: I worked on the original WOW and WOW64. Thanks for your work on Tiled, -Reed

I get a similar Error. It won’t load for me. I get:

The procedure entry point freeOpen_s could not be located in the dynamic link library msvcrt.dll

@thepermman Could you try a recent snapshot build to see if it resolves that problem?

I tried the earliest edition of Tiled, and it loaded up. We’ll see how that goes.

Edit: Loaded up a tileset. It’s working pretty well. I just need to test my unity plugin and see if that works. If that works then fantastic.

I use latest version on win xp 32 bit, i tried latest snapshot, but error “The procedure entry point freeOpen_s could not be located in the dynamic link library msvcrt.dll” still be.

UPD. I tried all latest snapshots, include versions for undefined windows - and error still will be…

@1115 This problem was fixed in Tiled 0.18.1. Please try explicitly uninstalling all versions of Tiled and then installing the latest version. There is a problem with the update process when going from an earlier version to Tiled 0.18.1.

On the other hand, Windows XP is no longer supported since Tiled 0.17. I’ll see if I can add a Windows XP-compatible build in coming days.

If somebody is still interested, please try if the builds I just made against Qt 5.6.2 work on Windows XP.

I’m getting another entry point error with the latest version of Tiled, AND there’s no apparent Uninstall file.

Okay, nevermind. What happened here was 1) I upgraded from 0.18, 2) I used the “Would you like to upgrade” prompt, which apparently left me no copy of the installer/uninstaller on my machine, so I just downloaded it manually from the side, ran it, chose uninstall (After choosing uninstall from the 0.18 installer), then reinstalled the latest version, and it works. Whew.

1 Like