Problem with collision editor

I am making a tiled-based 2d platform game in unity.

Whenever I open the Tiled Collision Editor and drag de cursor across the tile sprite to create the collision box, I can’t manage to make it perfectly matched with the edges of the tile, so that when I import the map in unity (using Tiled2Unity) I am unable to have all the tiles perfectly joined as 1 single and, mostly important, precise collision box.

What I want to know is: is there a way to have the tile perfectly matched with it’s collision box?

I’m using the latest version of Tiled and am on a mac if that helps in any way. Thank you.

[EDIT] I think I managed to, answers still appreciated though, so that I can understand if I’m doing something wrong


Try holding Ctrl while moving or Alt while resizing. That should snap to the grid.


1 Like

That did (I just had to hold cmd instead of ctrl because I’m on a mac, but it worked!). Thank you very much!

Just to note, you can permanently toggle on snapping to the grid in the View menu, where you can also enable “Snap to Fine Grid”, for which you can configure the number of subdivisions in the Preferences. That helps with placing shapes at exact slopes, for example.