Stretching screen

Hi! sometimes my screen stretches like this for no reason. The only way I get out of it is by switching tabs and going back in. is there a way i can prevent this or stop it? Thanks!

Also, when this happens to my screen, my cursor starts clicking to the far left of where the cursor actually is.

Did you enable “Hardware accelerated drawing (OpenGL)” in “Preferences > Interface” by any chance? If so, please try disabling this feature.

Nope, It is disabled