Tiled 1.0 released

At long last I’m proud to announce the release of Tiled 1.0. This release is based on a branch of development that started 1.5 years ago, with the goal of better supporting the use of external tileset files alongside map files. In addition I wanted to resolve all the loose ends that made Tiled feel incomplete. Last but not least, a huge amount of other welcome improvements were made by a record number of contributors!

This is a companion discussion topic for the original entry at http://www.mapeditor.org/2017/05/24/tiled-1-0-0-released.html

Congrats on the big release! I’ve already been digging into 1.0 features in the daily build and its great! :slight_smile:

1 Like

Congratulations on 1.0. I’m still on an old’ish version which runs perfectly fine but will upgrade right now. Thanks for all of your huge efforts!

edit: One thing that would be fantastic is if you could set the program to NOT ask about overwriting files. I waste so many mouse-clicks saying yes every time I export as :frowning:

1 Like

There’s two ways in current Tiled to avoid many mouse clicks:

  • If you export the same map again to the same file, use the “Export” action instead of “Export As” action.
  • If you frequently export multiple maps, automate it using the --export-map command-line parameter.

If neither of these work in your use-case, please open an issue about it and explain why, so we can consider this additional option.

Hi, I just upgraded to the new version on Mac. My polyline and polygon object buttons are reversed (I click polygon and it makes a polyline and click polyline and it makes a polygon). Is this an issue for everyone?

Also, thanks for creating this program. It’s very helpful.

I realized this too shortly after the release… only the high resolution versions of the icons are reversed so it shouldn’t affect too many people, but rest assured it’ll be fixed in the first patch release. Sorry for the mixup!

I knew your application in ichi.io and seemed very interesting tools (especially in hexagonal maps). I became the patron!! but only in $1 per month…sorry. Anyway I look forward to the future of this tool.


Guys, is it me or Tile Animations menu from “View” is gone? Same goes for Tile Collision Editor.

It moved to a separate “Tileset” menu that is available when editing a tileset. See also this topic.

Found it. Thanks!
I also had couple of “Not responding” when using paint bucket, but I cannot find exact steps to reproduce. Also had one on map resize. If I find exact steps, I am gonna send them to you.

@bjorn Congrats.

1 Like

On Windows 10 I spent a lot of time after install of v1.0.0 crashing it immediately by attempting to dock the tabs as I had them set up before. I am travelling so no access right now but wanted to post my issue in case someone can reproduce.

If I recall, the issue was dragging a window over an existing tab and releasing immediately, rather than (correctly) waiting for the pane to open up a space for me to drop the tab into (eg I wanted the layers info top left, with the properties bottom left, both in the same pane, both showing at once).

However, v1.0.0 is fantastic - it was like an early christmas as the new and unexpected features were just what I was hoping for. Thanks!

1 Like

On Windows 10 I can’t use the new version (1.0) at all. It crashes immediately after executing Tiled. I’ve tried both with x32 and x64 versions, but without any luck. Is there anyone else having the same issue? And maybe ist there anything we can do to make it work? Thanks a lot!

LE. It seems that the crash was because Tiled tried to open the last opened .tmx file at launch time. Now that I’ve renamed the file, it can’t be found anymore and Tiled opens properly. I don’t know however what caused this in the first place. Are there some breaking changes in the file format?

There shouldn’t be, but it could really help if you could e-mail me the file that was crashing upon load so I can test it.

You really shouldn’t need to wait for the animation to complete before dropping the tab. I tried shortly to reproduce this issue on Windows 10, but I couldn’t. If you find a way to reproduce it please don’t hesitate to open a bug report about it!

Whoa, the project has reached 1.0? This is excellent news! I’d just like to state my appreciation for this project as a whole, and just how useful it’s been. Thank you very much for making it. It’s everything I’ve needed in a map editor. :smiley:


Congrats on version 1.0! I’ve been using Tiled for just over a year now and I tell everybody that will listen about it.
New features sound amazing! Unfortunately, I can’t use them for the time being as all my maps are broken because support for .dds files has disappeared. :’(
Was this intentional? Can I expect .dds support to return or will I have to suck it up, remake my maps and hack up my source code?

Thanks for the great work!

Unfortunately, the DDS image reader that used to ship with Qt was disabled due to lack of maintenance (I wish they had written some more details on the exact problems).

I’m not sure what I can do to bring back DDS support. Earlier today, a note was added to the documentation pointing out that the handler can still be built from source for those who need it. This is something I could try to do, or actually anybody could try to build the DLL that way and put it in the plugins/imageformats folder of the Tiled installation. But it could be risky due to the security problems, though of course not if only used with your own DDS files. In any cave I’ve now re-opened #1169.

You don’t need to remake your maps though. You could instead convert the DDS files to PNG files for example, and change the file references in your map/tileset files. And then make sure to load the DDS instead of the PNG files in your game.

1 Like

Can we expect to see Tiled for mobile devices such as Android and IOS in the future?

I myself use my mobile to develop small games and demos using libgdx and AIDE and I plan to use tiled to make a small game (however I don’t plan to publish it, I just want practise) and I would like to use Tiled since I’ve used it before and it is very efficient.

Maybe. A few years ago I started a QtQuick based version of Tiled that is meant to be usable on a small touchscreen. However, it is currently still only a map viewer and I haven’t had time for it since almost two years.

It is mainly a question of priorities. I try to work on the things most useful to my supporters, which was for a long time to work towards a complete and fully documented version of Tiled. Now that we’re almost there, the choice is between further extending the features of Tiled and/or developing a new version that will also work on mobile devices. I could imagine to resume that project in September, after the GSoC students have finished their projects.

There have been others who have developed mobile tile map editors, with limited functionality. For Android there is Terrapin and for iOS there is/was iTileMaps.