Application not supported on this type of Mac (Mac10.6)


(Gaiamegu64) #1

As the title says I tried to open up TiledQT from 9.0 and below but I got the message above. the file information says its for Intel only but i have an intel core processor.

Model Name: MacBook
Model Identifier: MacBook1,1
Processor Name: Intel Core Duo
Processor Speed: 2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 2 MB
Memory: 2 GB
Bus Speed: 667 MHz
Boot ROM Version: MB11.0061.B03
SMC Version (system): 1.4f12

What can i do to get Tiled to work and if not what other programs similar to tiled that can wor for mac 10.6?


(Gaiamegu64) #2

Ok I figured out te problem. all tiled versions use 64bit and i have a 32 bit system. ic an use the java and it works wonders until i try to save any work. save as an image i get a heap size error, and if i save it as a tmx file i can open it again, but only for a few minutes or hours i don’t know, but what i do know is that I can’t open it again after some time has passed, getting an error message. is there any way i can increase the heap size for tiled 7.2 Java or is there a way to get tiled 32bit?


(Thorbjørn Lindeijer) #3

Hmm, I really can’t recommend using the old Java version instead. I think we did have 32-bit Tiled builds for OS X in the past, so maybe try older versions. You could start with Tiled 0.8 and if that works you can also try newer versions. See old releases on GitHub.

Alternatively, you can try compiling the latest version of Tiled yourself. It seems like Qt 5.9 was the last version of Qt to support 32-bit on macOS (see Qt for macOS), but Tiled can currently be compiled with Qt 5.5 and up so you should be able to get it to work.


(Gaiamegu64) #4

So I just select this on configuration and rn tiled through it? ./configure -platform macx-clang QMAKE_APPLE_DEVICE_ARCHS=i386


(Gaiamegu64) #5

Also no idea how to compile. at all.


(Thorbjørn Lindeijer) #6

No, those were instructions for compiling Qt itself, which you probably do not need to do. I expect if you download Qt 5.9 then you could compile Tiled against it in 32-bit mode, but I am not sure. Maybe I have time to try it this week.

Compiling just Tiled is not that hard, and I’ve described the process in Contributing to Tiled. Just be aware that 32-bit builds will not work with Qt 5.10 or newer, you’ll need to get 5.9 or older.


(Gaiamegu64) #7

I literally cannot find the 32 bit versions of these programs. at all. i keep going lower and lower and i keep finding 64bit


(Thorbjørn Lindeijer) #8

Hmm, maybe they don’t exist. I just found this old issue about it:


(Gaiamegu64) #9

Just my luck. is ther eany way to increase the java heap memory size for my machine then?


(Gaiamegu64) #10

Well it seems that im on a 32 bit system and cant increase the heap size. what is the max file size for tiledQT Java files when you save them?


(Thorbjørn Lindeijer) #11

Of course you can also increase the heap size on a 32-bit system. Just pass -Xmx1500m on the command-line for example to increase it to 1.5 GB.

There is no maximum file size. It mainly depends on the dimensions of your map and the number of tile layers.


(Gaiamegu64) #12

this is all i’m able to do. (a mockup showing the size i went iwth. 16x16 tiles, 200x200 dimensions) https://cdn.discordapp.com/attachments/391950767541583882/457545451126784012/megamancastlemadness.png

I mean i cant save it as an image file if i add any more tiles or sprites.


(Thorbjørn Lindeijer) #13

I don’t know why it won’t let you save as image larger maps, but I’m no longer working on the Java version of Tiled since many years now and have no plans of coming back to it. I think it would be better to look for a way to get 386 builds of the Qt version of Tiled for macOS working.


(Gaiamegu64) #14

maybe i did something wrong. it wouldnt let me identify the name of tiled when i replaced java.jar with tiled.jar. i think part of the problem s that im using 16x16 tiles, but when i save images using 32x32 or larger it has no problem with it, especially when i use 16 o 32 bit sprites.

Edit: well i found a solutin somewhat. on a whim i opne it up again and i saved after adding more tiles and voila it did! tried again a second later and i got the heap size error. seems the memory is at its biggest when i open the tmx file and no other time, or when i save for the first time.