Automapping misaligned on hex grid

I am trying to create coasts on my map using automapping.
However, when hexes are placed on odd rows, the automap becomes misaligned.

See how the first and third rows have the coast tiles nudged one space on the right with the furthest right one wrapping back to the left.

This is what my automap looks like and as far as I understand, this should be working (there are region tiles underneath).

I feel like this could be a bug but at the same time it’s my first time using auto-mapping and I’ve probably done something wrong.

Here is an example project with the tileset, and rules in place. Only the first green tile has the rule set up and it needs to be placed on the Biome layer.

Any help would be appreciated.
Thank you : )

You’ve done nothing wrong, this is a known bug: Automapping doesn’t work correctly on staggered maps (this includes staggered isometric too, not just hex).

Relevant issue on GitHub: Automap does not work correctly for staggered maps · Issue #3089 · mapeditor/tiled · GitHub

That’s unfortunate but thank you for figuring it out.

Is there a workaround (like making the rule map orthographic or something) or do I just need to wait for an update that fixes the issue?

Theoretically no, but I think in 1.9, using the new rule properties, you can make two versions of each rule, one that runs on even rows, and one that runs on odd rows and accounts for the stagger offset. I haven’t tried this myself, but with some experimentation you might be able to figure it out :] You’d set the ModY property on all rules to 2, and set OffsetY to 1 on the offset versions of the rules. A single rule options rectangle can cover multiple rules, so if you organize the rule map appropriately, you should only need two rectangles for all the rules within a map.

Changing the map’s type would not work, as the problem is the staggering, which non-staggered orientations can’t account for (and neither can Automapping, currently xP). If you turn that map map back into a staggered map, you’ll just get those same distortions.

Complaining Mentioning that you’re affected by this bug on the GitHub issue might help it get resolved sooner :]