Trouble with AutoMap

I’m using tiled 1.0.3 from the main site.

Was trying to follow a tutorial on youtube… I made 3 layers for my ~rule.tmx file. regions, input_Ground, and output_Fringe. Made a 2 by 2 square on regions, placed 1 tile on input_Ground, and placed one tile above it on output_Fringe.

Tested it and it worked as expected. But then tried to place extra tiles on output_Fringe adjacent to the previous one… and tried to automap and got nothing. And what’s strange is that undoing the changes and trying to automap the previous configuration doesn’t work now either.

Thanks for your time guys.

Strange… Maybe the tutorial was outdated or something. But using regions_input and regions_output instead of regions seems to have solved my issue.

Are your input and output regions different? If they are the same it should be possible to use a single regions layer, otherwise you may have found a bug.

I’m actually still having a problem… I’ve tried almost every configuration available… Currently reading and several youtube tutorials. No configuration is producing what I need to produce walls.

I’ll upload some photos in a sec for further illustration.

Thanks for reading my post :slight_smile:

Here’s one of the issues I’m having

The overall automapping processes seems to be buggy in general. Sometimes it behaves as expected following guides, and sometimes it just doesn’t. But I don’t know what is a glitch and what isn’t since I’m new to Tiled. For example there was an instance where I got something to automap the way I wanted… but then I had to click the automap several times to get things to spawn, and sometimes they didn’t. Holding A ensured that eventually everything did map.

Thanks again for addressing my issue. I love Tiled. It’s an awesome tool :slight_smile:

edit… oh right… to answer your question… I’m not sure how Tiled automapping works… So I tried regions_input and placed some empty spaces in input_Ground and walls in the same spot in the corresponding output_Wall layer, but whenever empty spaces are involved it doesn’t seem to work. And whenever there aren’t, it doesn’t produce a desired wall effect. And using “regions” simply doesn’t work as illustrated in the link.

Could you share the actual files you’re using, so that it may be easier to debug the issue? You should be able to upload a .zip file as part of your post.

Hmmm… says that new users can’t upload attachments… I’ll try to find another site to upload my zip file

Edit Here we go

Thanks again!

Were you able to confirm that this was a bug?