Automapping not working

Hi, automapping is not working with embedded tsx. Its works fine with external tsx but its not working after I clicked embed tsx button.

Is the tileset embedded in both the automapping rules and the working map, or just in one? Tiled will attempt to match similar embedded tilesets (even though technically, those are different tilesets), but an embedded tileset and an external tileset are considered different, I think.

In general, you should not use embedded tilesets in your maps. If you need embedded tilesets for some reason, it’s better to use the embed tilesets export options, that way your production files can have embedded tilesets while your authoring can use external tilesets.

1 Like

I was going to reply to tell that I solved the issue then I saw your comment, thanks for helping ^^. Issue solved after I embedded tilesets in automapping rules too. I’m embedding because of phaser.js -_-

As I wrote above, instead of embedding the tilesets into your automap rules and your working maps, embed on export, and export to different files. You can also use “repeat last export on save” to automate these exports. This way, you avoid all the inconveniences and tedium of working with embedded tilesets, but can still have embedded tilesets in the files you use with Phaser.

I replaced all embedded tilesets with external and now I’m importing them when on save as you said. I didn’t know this before you said. Thank you it helped a lot.