Command button isn't working


I’m trying to export my project to Unity using Tiled2Unity. I put in this command, and I get an error, “The command failed to start.”:

open -a "/Applications/" --args %mapfile

I thought maybe the error was maybe due to a typo, but these commands yielded the same result:

open %mapfile

/Applications/ %mapfile

echo "Hello World"

Hopefully I’m posting this in the right place. I saw this post, but none of the stuff there seemed to help.

Which Tiled version? I just tried with the latest development snapshot and couldn’t reproduce the issue. Some notes:

This would not do anything because it would try to open the current file in Tiled, and Tiled just detects that it’s already open and the “current file”.

For me, this started TextEdit, but then TextEdit complained that it didn’t have permission to open the file. No idea why, because the open -t %mapfile could open the map fine in a text editor.

This command won’t be visible unless you right-click the entry and choose “Execute in Terminal” (or you open the Debug Console window, which can show the command output in the development snapshot version).

I’m running Tiled 1.0.3 on macOS 10.13.1

I tried to replicate what you got, but running /Applications/ %mapfile through Tiled gave me the same error. Running /Applications/ path\to\mapfile through the system prompt led to the .tmx opening in TextEdit with no issue.

I’ve just tried this, but nothing pops up in the debug console, and I still get the error message “The command failed to start.”

Is it possible there are compatibility issues with the 9 November 2017 macOS update?