Crash to Desktop When Using Fill Tool

I’m trying to fill in a semi-large area of my map with “water” tiles, but it always crashes to desktop whenever I try. I get this error when I ran the debugger:
"Unhandled exception at 0x0929FD25 in tiled.exe: 0xC0000005: Access violation reading location 0x0D4AB000.

If there is a handler for this exception, the program may be safely continued."

I’ve tried sectioning off smaller areas in case it was some sort of memory error, but even with a 25x25 area, it still crashes without fail.

The problem has ceased for now, but I’m not sure if it’s gone.

Without more information about how to reproduce this crash there’s not much I can do. Just to be sure I played around with the fill tool a bit myself as well in the latest Tiled version, but I could not get it to crash.

Please do let us know if you ever run into it again and maybe have some more specific details about the situation in which it happens. Unfortunately these problems normally stay until they are fixed.