Exporting from Tiled to GMS 1.4 not working?

Hello to all,

so I am pretty new to Tiled and also to GMS but I have read and watch a tone of tuts already and created some example games to learn the mechanics of GMS and also of Tiled. My problem for the moment is that I want to export a map I created with Tiled to GMS, for which I already researched any forum or option to do so, here some examples of what I did and tried until now:

  1. http://gmc.yoyogames.com/index.php?showtopic=583235
  2. http://discourse.mapeditor.org/t/built-in-support-for-exporting-maps-to-gamemaker-format/1341/2
  3. Wanted to put some other links but since I am new I am only allowed a max of 2, I check several more!
  4. I have tried all 3 Tiled releated apps in the marketplace.yoyogames ( even the paid one, where I sent a email to the creator but no answer came back ) but nothing worked for me.
  5. I also did the thing with creating the .tmx save and converting it into a XML in the Map Property section but the only thing which changed was the when I imported the file into GMS to my rooms and opened the room, instead of a grey room i got a black room, but no showing of anything of my map!

For testing I am using tile size 128x128 tiles, map size 100x100 tiles and the map I created to test and make the process is the following image

First I thought it would be as easy as export the map as a .room.gmx and import it into GMS and have the corresponding tileset in backgrounds integrated so it should work, which was not the case, so I am finally at the end of what to do or how to solve this.

I hope sincerely that this is just a stupid mistake from my side and that anything will work or that someone could help me out, with how to export my created maps in Tiled to GMS, since I really want to start working on a game!



Actually since Tiled 0.18 it’s really almost that easy, since it natively supports exporting maps to .room.gmx files. A few fixes and improvements to this were also made in Tiled 0.18.1 (and for the upcoming Tiled 0.18.2, support for image collection tilesets is pending).

The part that Tiled doesn’t do currently, is to export anything else but the map. So you need to set up your tilesets and objects in GMS as well, with the same names as used in Tiled (for objects, the “Type” property refers to the object name, whereas “Name” becomes the name of the instance). The exported .room.gmx file should then work fine.

I am doing that already but it is not working at all.

OK just did that and it didn’t worked. I am going to make a small video showing you what I am doing. If something is wrong what I am doing then you should be able to see what it is. brb with the video!

Hi, so finally I have made a small video as said,where you can see all what I am doing to export the map from Tiled into GMS. Hope this helps to find out if I am doing something wrong or if there is a error or bug. Thanks a lot!

@Gokuss7 I think the problem is the space in the name of the tileset. GMS is automatically replacing that with a _, whereas Tiled just keeps it as a space.

The easiest way to do it right is to first add the tileset in GMS, and then to select the image file from your GMS project directory when adding the tileset to a map in Tiled. That way the name will always match up correctly.

1 Like

OK I am going to try it right now without spaces in between and also doing it like you told me and let you know in a few min how it went!


Hi Bjorn,

Vielen Dank, es hat geklappt :slight_smile: Thank you very much it worked. It seams that the problem was that GMS when I integrated the tile name it made the automate separation with the _ like you where saying and because of that it was not able to find the tileset.

Take care and thanks again for helping me!

1 Like