How to put popout windows back into main window?

I popped 3 views/toolbars out of the main window, but can’t seem to get them back into the main window. When in the window they have a symbol next to the ‘x’ that means to ‘popout’, but when popped out, there’s no symbol to return it to that state. I tried resetting the layout to the default view, but all it does is reload the windows in their place. Anyone know the obvious answer that I can’t seem to find?

Included a photo to reference what symbols I’m referring to.

Normally, when you drag those windows by their title bar over an area where they can dock, the main window below makes room and you can release the view there to dock it again:

Does that work in your case? If not, please tell the platform and version you’re using.

The “View > Views and Toolbars > Reset to Default Layout” action should put them back into the main window as well. I just tested this on Windows in the development version of Tiled compiled against Qt 6.4.2.

Dragging them was the first thing I tried. Just now I’ve tried again and still nothing. I am using version 1.9.2 on Fedora (Linux). Downloaded via Flatpak/Flathub.

Tried “Reset to Default Layout” again and it still only refreshed the windows in place - not reincarnated in the main window.

I just tested on Fedora using the Flatpak and it works for me, but since I see you have different window frames, I guess you’re on Wayland whereas I’m on X11. It could be that the re-docking feature is broken on Wayland.

I would suggest you reset your configuration and avoid undocking the views. For the Flatpak, the config file is stored at:


You can either delete the file or just the keys related to the layout, like mainwindow/state, MapEditor/State and TilesetEditor/State. Make sure to do it while Tiled is closed.

I was looking through the hexes of each setting in the conf file to see if I could figure out which hex pertained to the window problem :sweat_smile:

Of course deleting it worked. Thank you kindly! Pesky Wayland…