Issues with Hexagrid Map


I just tried to create a hexfield map. Therefore, I created some 64x64 pixel Hex-Fields, created a new map in Tiled, choose Drawing order right-down and a tile size of width 64px and height 96px (other where not fitting properly).

So far, I have following issues: I think it is strange, that I have to enter such a strange pixel size in order to get it placing the tiles on the right spots. Also, the blue area that should show the tile position still seems to be a normal isometric 4-edge one, as can be seen on the following screenshot:

Another issue are the spaces between the tiles. The gras tile has an alpha background. Whenever I move the mouse pointer from the bottom right to the top left over the map (whitout drawing tiles at that moment, just moving), thoose empty 1px wide spaces appear in the map.

The last point I have is about tilesets: I loaded all the single png images and created a new tileset package (.tsx file). But when I create a new project, I’m only able to load that tileset via the map menue entry on top. I would expect, that I could do the same via the button right next to the create new tileset button on the tileset management window.

And the last point: I would like to edit my created tileset, so that I can add additional images to it. would that be possible? Otherwise I have to create a new one for every new tile image that I create…

Alright, thats all, I hope my comments help you to improve this cool tool. I’m really glad I found this software and I want to say: Thank you very much, keep up the good work! I really appreciate it.

I wasn’t allowed to post two images because I’m a new user, but I still want to provide the single tile image I used for you to see if thats the reason for the gap. Here it goes.


since I unfortunatly have no experience with the hexagonal maps yet I can only try to reply to some questions:

Do you have OpenGL rendering enabled in EditPreferences?
You might want to try to flip that settings and see if the drawing glitches are gone.

@bjorn: Couldn’t the external tileset be provided as an Type in the New Tileset window? (Just like Collection of images?).

The best way to edit tilesets I know is to close tiled, edit the tileset and reopen the map in tiled.
When editing make sure you only add tiles to the right or buttom of the existing tileset. When tiled opens the map then it detects that the image size differs from the image size it saved for the tileset and recalculates the tile ids.

Shuffeling tiles around is more complex since tiled cannot possibly know what tiles you shuffeled… So this needs additional manual work in tiled (or via a tool).

Note: The procedure above is only required for adding/removing tiles. If you only want to change the way a tile looks you can simply do this while tiled is open. Tiled will simply reload the tileset after it changed on the disk and will display the result.

Hope this helped,

Ah, nice, the open-gl thing fixed the alpha pixel issue. However, the preview tile (the blue iso-4-square) still looks weird.
For the tileset edit I thought, that the sets are a convenient way to store my tilemap collection, and I would prefer if I don’t have to open and edit them with another program than what I used to create them. It would be nice, if I could just load a tileset pack, add additional images to it and then save it as if I create a complete new one. And that whithin the program.

Edit: I had a look into the tsx file and I noticed that I made a missassumption. I thought, that all the images I added are contained in that file, but instead, it is just a list of references. So my suggestion is, to create a container format that contains that reference file AND the images, for easy exchange purposes.

The issue with a custom tileset pack format would be that you lack all the great tools you can use to edit simple png files. So tiled would have come with image editing features too… That would be a massive amount of work to implement and maintain (and it would still not be as good as standalone image editing tools).

The most important thing you missed is that you did not set the length of the side of the hexagonal tile in the map properties (Map -> Properties…). This would fix your hover highlight.

And to edit external tilesets (.tsx files), including adding/removal images to an image collection tileset, you need to temporarily “import” them into the current map you’re editing and then “export” them again to save those changes.

The drawing glitch may be a bug in Tiled.

@bjorn: Ah, ok, that fixed the overlay issue completely. I missed this, because it was not part of the “create new map” dialogue. And I also managed to edit external tilesets now. For people who get to this post having the same issues:

When you create a Hex-Grid map with 64px times 64px tiles, you have to create a new map with the width & height parameters set to 64px each and after that, you also have to go under Map->MapProperties, look into the lower right corner (the settings menue is not a popup menue, it just appears on the lower right) and change the “Tile Side Length (Hex) to half of the tile pixel size you choose (i.e. 32px)”. I’ve made a screenshot:

If you want to save your tile set, you can use “Export Tileset As”. However, if you want to import it in another map, you have to use the top menue “Map” -> “Import external Tileset”. If you want to edit this tileset (add images etc.), then you have to push the butten right next to the “new tileset” button on the right tileset menue. That converts it into a normal tileset and then you can remove or add tiles from it. Remember to export it after you did so to save the changes!

Thanks for all who helped!

thank you so much