It can't work well on Apple M1 Pro Monterey

Tiled 1.9.2 is often stuck . My computer is Apple M1 Pro Monterry。

Please provide some addition information. For example, did previous versions work fine? If so, does the problem go away if you use the older version? Also, what does “is stuck” mean? Does it stop responding? Does it do this at random or is there a pattern? Does any error or crash dialog show up?

I can possibly provide some extra information here.

I’m using a top spec M1 macbook 16 inch.

Using version 1.9.2, the animations all work nicely so the render speed of the map seems fine but any interaction at all with any aspect of Tiled, including just howering over things or trying to use the main toolbar is weapons grade laggy… like 30 seconds of delay.

Does not appear to be obviously CPU or GPU bound as my Macbook doesn’t really work any harder when I open Tiled, it just seems to take half a minute to do anything, and the more events you trigger (hovers, clicks, etc) exponentially increase the delay before you can interact with anything.

I have the same issue on my M1 Macbook Pro - What I see is that Tiles is stuck at 100% CPU (of one core).

I was on 1.7.2 when encountering the sluggishness - an update to 1.9.2 did not help.

Edit, forgot to say: I am on macOS 13.0 (Ventura).

+1 for this. M1 MacBook air on macOS Monterey. Tiled works fine for a little while, but then starts to hang with a spinning wheel and some CPU stuff going on.

Screen Shot 2022-12-16 at 11.59.47 am
Screen Shot 2022-12-16 at 12.00.15 pm

To everybody who was having issues with Tiled 1.9.2 running on Monterey or Ventura, please try updating to Tiled 1.10 and let me know if this problem is fixed. For Tiled 1.10 I’ve updated the Qt framework from 5.15 to 6.4, which might have addressed these issues.

(just be sure to take the “macOS-10.14+” download and not the “macOS-10.12-10.13” download provided for compatibility)

Hello, I installed Tiled 1.10, 1.9 and 1.8 and all versions have the same problem. Tiled is randomly stuck loading. I use an older Macbook Pro 2015 but with Monterey installed. Same problem as described by @junkmate383.

First off, I want to take this opportunity to say a big thank you to Thorbjorn for the tool you’re sharing with the community.

Tiled 1.10.1 doesn’t work as well for me on Apple M1 (2020), macOS Monterey 12.3.1.

Machine specs:

Screen recording:

The screen recording doesn’t show it, but after clicking the icons, I am met with the spinning rainbow of death and I just need to force close the application.

For anybody experiencing issues running Tiled on M1 or M2, please try the new Universal build available at:

  • Make sure you’re logged in to GitHub
  • Scroll down to Artifacts
  • Download the macOS 10.14+ build

And don’t forget to let us know if this addresses your issues, and whether it introduces any new ones. Thanks!

Still the same issue. I’m on the macOS Ventura m2. Thanks for working on it and providing such a great tool

@arcanereinz Can you please tell us the exact version you’ve downloaded? Did you get the above build, which is 2 months old now? If so, please also check if the Tiled 1.10.2 release is still affected:

Tiled-1.10.2_macOS-11+.zip

i installed last version and still problem on mac m1

Yes I’m using Tiled 1.10.2. I’m on macOS Ventura 13.5.1

1 Like

Same here. I’m on M2. The latest version freezes randomly. High CPU usage.

same here. last version of app.

I’m having same problem, I’m using mac (M1 chip) ,OS Sonoma 14.2.1, I tried using older versions of Tiled as well. Current issue is that I get the spinning wheel of death, this happens after a minute of using the App. This causes the app to freeze and I have to close it out and restart it. It always crashes after the same amount of time.

I think there was no longer an issue open for tracking this, so I’ve opened one:

I don’t have access to a macOS running on Apple Silicon myself. Any help with investigating this issue would be really appreciated!

I got this to work by downloading source to my m2 Mac and compiling under qt.

The file dialogs all pause when opening but become responsive within a couple seconds. Probably something there just haven’t had time to look yet.

I wonder if the author has access to a Mac m[n] environment or access to GitHub actions to handle the binary compile?

Hats off to the developer for having a super clear readme file allowing me to easily build it.

To anybody who’s running into issues, can you please help with testing whether the Qt 6.6.2 based Tiled builds fare any better? They are available for download here, provided you are logged in to GitHub:

The relative file (under Artifacts at the bottom) is “Tiled_macOS-11+.app”.