[Mac OS 10.7.5] Window moves when drag-selecting

The title says it all really. The window moves when attempting to drag select. For example, if I click and drag within a tileset to select multiple tiles, the entire window moves. Another example, if I’m attempting to select objects in an object layer, the entire window moves.

That sounds like a very annoying bug. Do you know since when this is happening? It certainly didn’t used to happen, so I think it may be since updating to Qt 5.5. I’ll have to find some to time to test it.

1 Like

This is my first time using Tiled, therefore, this bug has been occurring for at least a week, which is when I downloaded Tiled, played around with it, and consequently experienced this bug. So the version I’m using is 0.14.2 for Mac (which you can see below to verify).

The software looks great so far other than this bug btw :wink:

That’s nice to hear!

I’ll aim to have a look at this issue soon, latest on Monday. In the meantime, since this bug sound pretty serious, you may just want to try older releases available from here:

1 Like

I tried 13.1, it had the same bug, then I tested out 12.3 and the bug was squashed.

I’ve just tried it on my MacMini, but unfortunately could not reproduce it. I’m on OS X 10.10.5 at the moment and tried with Tiled compiled against Qt 5.5.0.

Unfortunately I can’t downgrade to see if it’s only on older OS X versions. I’ll upgrade Qt to 5.5.1 and my system to 10.11.

Hrm, also can’t reproduce on OS X 10.11 with Qt 5.5.1. Could you try the latest daily build I’ve just done there? It’s available at http://tilemapkit.com/tiled/?C=N;O=D - tiled-2015-12-21.dmg.

Apologies for the late reply. This build doesn’t seem to work. Since you can’t downgrade, I can let you test it out on my computer through TeamViewer. For security reasons, I don’t want to leave my Team Viewer connection information on an open forum.

Leave me an email and use my PGP key when necessary. My fingerprint is 4516 8971 9556 13E5 E2DB D83E 6623 EBE9 C159 DE23. I’ll reply back with my Team Viewer ID and Password. I’ll leave my computer open whenever possible so you can test and debug.

I noticed that Tiled version 12.3 includes the following in main.cpp:

#ifdef Q_WS_X11

Then in version 13, these lines are missing. It’s also when you upgraded to Qt 5.1.0. On Mac OS X, Apple shipped X11.app (now known as XQuartz) with OS versions 10.5 to 10.7. I’m wondering if the X11 is being used. If it is, perhaps the graphics system affects drag selection.

I would build myself to test it, but I’m having some issues with brew that I don’t want to bother with at the moment. Also, I looked around at your source code to see what other possibilities for problems there might be. So far, I haven’t found anything else.

Can you describe what doesn’t work about it or show a screenshot? Thanks for offering to have me test it through TeamViewer. I’ve never used it but I’m looking forward to try it once I’m back home (currently visiting family).

Tiled does not use X11 on OS X. I believe I simply removed the line because with Qt 5, the “raster” graphics system is already used by default on X11. But it has nothing to do with this problem.

Specifically, the same bug persists. Other functionality works as expected. When you’re back home, just shoot me an email. :christmas_tree: Enjoy the holidays with family while you can :smile: :christmas_tree: