ST2U/Unity reporting "TiledMaps/base tileset.tsx" missing but when open Tiled there is no error

Basically what I said, Unity says “SuperTiled2Unity version: 1.10.3, Unity version: 2019.4.30f1
Missing tileset asset: …/…/…/…/TiledMaps/base tileset.tsx” but when I open up Tiled there no place to locate base tileset.tsx or even any mention of it being missing, I know these aren’t the ST2U forums but I figured there would be knowledgeable active members hear.

Two things you may want to check:

  • Are you sure you’re opening the exact same file in Tiled? The file in your Unity project? Such problems often happen after copying or exportig a map file into the Unity project, whereas the intended workflow is to save the map into the Unity project and edit it in-place.

  • The number of “…/” in the tileset path looks suspicious. Are you sure the .tsx file is also part of your Unity project?

If you need to change the tileset reference in the map file, you can do this either using a text editor or by opening the file in Tiled and using the small “Replace Tileset” button below the tileset view.

Thanks for the suggestions, the .tsx file is definitely in my unity project, as for the file in my unity project I’m almost positive that they are the same file, I have imported and re imported the tiled map several times. I’m not sure what I’m doing wrong or if I’m just misunderstanding your instructions.

p.s. I have tried with other maps and still get the same error