Terrain tool issues

I watched the tutorials, including the terrain one. I then tried to create some terrains with the standard Zelda; A Link to the Past tile sets.

Hours later…

I can’t get it to work. I tried using the standard tiles. When that didn’t work I opened photoshop and modified them to get them to look similar to the one in the tutorial. Still didn’t work. Either it goes berserk (like in the picture) or it’s just a one-color cell when I use the terrain tool.

What am I doing wrong? And are there any png files out there that have been set up for some terrains with these tile sets? Like zelda water, zelda dirt, etc.?

Also, not sure if it matters, but I am using 8x8 for everything, instead of 32x32. But my tilesets, terrain, and map are all 8x8, so I know I’m not using different dimensions which I know does not work from looking at some other threads.

Are you maybe simply missing a full grass tile? I don’t see it in your screenshots.

Btw, I see you have two tilesets with terrain. Just note that terrains from different tilesets won’t work nicely together on the same layer at the moment.

I think that was part of it. I had to create some new tiles to complete the gaps as well.

I’m guessing the color palette needs to be exactly the same in order for the terrain to “recognize” when it’s bumping into a familiar tile? Before I may have been using colors that looked the same, but were slightly different shades

No, that has really nothing to do with it. You tell Tiled how the tiles connect by editing the terrain information. There is no automated matching of tiles by their contents.

But if you’re missing essential tiles like the full grass tile, then Tiled will have a lot of trouble making things work and this currently results in a big mess.


I think the terrains has some problems with tiles below 32x32

I’m trying to make terrains with tiles of 16x16 pixels, and they don’t match, i tried it several times, but hey don’t work porperly…

Why 16x16?

Well, some users use RPG maker 2000 and 2003 jsut trying :slight_smile:

Please don’t bump old topics to discuss different issues, make a new topic instead.

Terrains work fine with my 16x16 tiles and I’ve worked with 8x8 before with no issues. Make sure you’re not missing some terrain shapes or accidentally mislabelled some tiles, those are the usual sources of issues with terrains.

1 Like