Tiled.exe overriding .exe files yikes! help!

This isn’t a problem with Tiled, it’s working perfectly, but it’s an inexplicable problem being caused by Tiled. I was tired of constantly needing to manually navigate to open .tmx files, so I wanted to tell Windows (I’m on Windows 10) to open .tmx files with Tiled.exe by default, the same way one can change the default for opening .jpg files or .mp3 files etc. But something went wrong - I set it and indeed it now opens .tmx files with Tiled by default, and their icons appear in Windows Explorer as the Tiled file icon, but somehow it also made the system decide to use Tiled.exe as the default program for opening all .exe files which means anytime I try to start any program it attempts to open the program in Tiled instead of running it, which, of course, fails. This means I can’t start any programs, including (the hard part) the command prompt, registry editor, VPN, all web browsers, and the Task Manager, which disables basically all methods I could use to fix it.

I know you can go into windows settings via the control panel and tell Windows to reset to default which programs it uses for which file extensions, but that only reset which programs it tries to use for web and email, it didn’t affect this. Going manually through the Control Panual into the big list of which programs Windows uses for which file extensions didn’t have .exe in the list of possible file extensions one can modify. And Tiled.exe doesn’t appear in the list of applications one can uninstall in the Add and Remove Applications screen, so I can’t uninstall it.

I still have access to Windows Explorer because it seems that the computer is switching to using Tiled.exe for .exe programs mid-way-through-booting-up, and it does succeed in running .exe programs before that point, so each time I restart it gets to a certain point and then starts giving a jillion error messages, but it does manage to open windows explorer before that point. However if I close windows explorer and try to open it again, it tries to do the Tiled.exe thing again, and fails, and you have to restart.

It does still work to log into the computer under a different windows account, you can login via the my work’s sysadmin account instead of my personal account and it does work, but we haven’t worked out a way to use that account to change this problem in the personal account.

Any ideas? Right now it’s completely disabled the whole computer, everything except for Tiled itself, so Tiled is the only thing that does run.

Aha! Solution:

  • open powershell running as administrator
    • type ‘powershell’ into the system search bar
    • right click on the app that is the first result and select ‘run as administrator’
  • type reg load HKU<username> C:\Users<username>\ntuser.dat and hit enter
  • if you get ERROR: The process cannot access the file because it is being used by another process. then:
    • open up task manager
    • go to the Users tab
    • sign out the user you are trying to modify by right clicking on their name
    • go back to powershell, hit the up arrow to re-enter the command and hit enter
  • if you get The operation completed successfully. then proceed
  • open regedit
    • type ‘regedit’ into the system search bar
    • select the app that you should get as the first result
  • navigate to the following path in the registry editor:
    • Computer\HKEY_USERS<username>\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.exe\OpenWithProgids

Still no idea what caused it in the first place, though.