Tiled opens the immediately closes? (Windows 10 64 bit)


(Noah Hall) #1

This is very weird…

Half an hour ago, Tiled was working just fine. But for whatever reason, it won’t open. It opens to a white, blank window, then closes about a second later. None of my maps open. Here’s what I’ve tried so far:

Reinstalling Tiled 64 bit for Windows.

Uninstalling that, then installing fresh.

Uninstalling that after it didn’t work.

Installing 32 bit.


I’ve got nothing. No ideas at all what could be the issue. I restarted my computer inbetween all of these, still no dice. Very odd!

Any help is appreciated, thanks in advance :smiley:


(Thorbjørn Lindeijer) #2

Did you by any chance enable hardware accelerated rendering (OpenGL)? This could introduce such stability issues. If that is the problem, you can get Tiled to start again by launching it from the command line as follows:

tiled --disable-opengl

Since you’re on Windows, Tiled will not be in your PATH, but you can run it using cmd from the right directory or create a shortcut that passes that argument.


(Noah Hall) #3

That did the trick, thank you very much! Here’s something interesting to note:

Last night I ended up getting Tiled to work on accident by opening a tileset. For whatever reason, opening a tileset worked fine and I’m surprised I didn’t try that earlier. I could then open up a tilemap from there once I got the application open that way. Trying to open Tiled either from the .exe or from opening a .tmx still produced the opening-closing result.

Figured I’d let you know I could still open it from tilemaps in case that helps you in any way :+1:

Thanks again, I appreciate it!


(Thorbjørn Lindeijer) #4

Ah, that makes sense, because tilesets are not currently rendered using OpenGL and when opening a file directly, Tiled does not open the files that were open last time.