Tiles not showing up in preview


(peterb) #1

hello a while back i had a collision problem which is now solved, i am having a strange new issue. i am placing tiles in my map, and they show up there, but when i go to preview the map they dont show up, nor do they show up in the game. it is strange since i already added some of these same tiles today and they worked fine. what could possibly be wrong?

thanks,

Peter B


(Thorbjørn Lindeijer) #2

Did you solve your issue in the meantime? Since this could be an issue with Tiled2Unity, if you still have it then maybe @Seanba can help you.


(Seanba) #3

Hi there. If tiles are not showing up in the preview then they won’t be exported to your Unity project either. That could be because you currently have that layer hidden in Tiled or that layer is using the unity:ignore custom property.


(Anton Mr) #4

I got the same problrm here. I’m a newbie at game making.
When I starting 2d game tutorial and open tile palette . it show a black preview. But somehow I still can put add the new tile to the scene.


(Thorbjørn Lindeijer) #5

@Anton_Mr Are you using Tiled or Tiled2Unity at all? I can’t tell from your screenshot. Hopefully @Seanba can help out here, because I do not have experience with Unity.


(Anton Mr) #6

it is unity. But am I asking at wrong web ? Because I thought this program is extention of unity.


(Thorbjørn Lindeijer) #7

You’re asking on the forum for Tiled, an independent level editor for which there exist several solutions for using its maps in Unity, one of them being the Tiled2Unity exporter. If you’re using a Unity level editor extension or the tile map functionality in Unity itself, then this is indeed the wrong forum to ask for help.


(Anton Mr) #8

@bjorn I see. thanks for the info.
But , this forum look helpful for me to learn something about tiled that used for 2d game.
so I will still around to learn


(Thorbjørn Lindeijer) #9

You’re welcome to stay and ask questions! All I meant to say was that you’re unlikely to get an answer here to the specific question you asked. :slight_smile: