When disabling "Show tile animations" show 1st frame

Currently when you have animated tiles enabled, and you choose to disable it, the tile animation stops at the frame that was playing when you disabled it.
However, I propose to change this to always show the first frame of the tile animation, regardless when the tile animation was disabled.

If that’s not something others would be happy with, at least consider adding a setting for that.

The reason I’m asking for this, is because, when I was exporting my tilesheet on the map as .png, I forgot to disable “Show tile animations” and it resulted in all my tiles(that were marked for animation) 1st frame being overwritten with whatever frame was playing at that moment.

Although this may sound like a dumb suggestion, I hope you consider it, thanks.

1 Like

I didn’t even know it did that, that sounds like an oversight!

I’m pretty sure Tiled was recently updated to reset animations to the first frame any time an animation changed, to keep them in sync. Hopefully that same code can be reused to reset animations when they are disabled.

Right, I think that makes a lot of sense so for now I’ve just changed this behavior without introducing an option for it:

Thanks for bringing this up!

Cool, thanks!
Does the latest (1.7.2) version that is available for download have this change or I’ll have to wait for next update?

If you’re logged in to GitHub you can download a build with this change at https://github.com/mapeditor/tiled/actions/runs/1208830171, there’s packages available for each operating system (scroll down to Artifacts). Just note that these builds also include new features, like support for custom enum properties, which are still subject to change until the next release.

Otherwise, the change will most likely be released with Tiled 1.8, which should be later this year.

1 Like

Oh great, I tried it and it works, amazing!
I have one more suggestion that is related to this topic (if it’s not ok to post it here, I’ll create seperate post for it): currently, when you use “Export as image” feature with “Show tile animations” enabled, the map will be randomly “screenshotted” with whatever tile animation was playing at that moment and put into image. This results in unpredictable image upon export.

I’m not sure what would be a great way to change this, but I propose doing something similar: set 1st frame of all tile animations before exporting map as image.