Cant get autoMapping to work

I created a simple level to test out automapping , all of it with 1 type of block ( ID 0)
Went over and created another tilemap called “TempMap Rule” and a rules.txt in the same folder as the test level referring to that “TempMap” Rule folder
created a input_prototype layer, output_prototype layer
with the input_prototype containing only ID 0 tiles (same ones from the level map)
and in the output_prototype 2 random blocks to check
i tried with 2 simple ones like in the photo, saved and went to try on the level map
the * icon appears on the name of the Level when i press CTRL+M , so i know something is happening, but nothing is showing
Here with the ID 0 tiles with opacity on the output set to 0 so we could see the ID 0 tiles

Here with opacity back on so we could see the tiles it should transform to through outptu

and here it is after pressing CTRL+M on the level map

1 Like

Your rules are looking for a layer called “prototype”, but your working map only has a layer called “Tile Layer 1”.

(Also, your smaller rule will supersede the larger rule. If the brighter blue tile is meant to be output when the prototype tile is isolated, you’ll want to check for Empty around it.)

1 Like

The prototype renaming solved it , thanks!
What do you mean though by “check for empty”?

1 Like

I mean check that the tiles around it are empty (have no tile). You can do this with the MatchType “Empty” special tile. The easiest way to access this special tile is to add the Automapping Rules Tileset to your rules map (Map > Add Automapping Rules Tileset), it has all the special tiles in it.

1 Like

Thats amzaing, one more question
After i automap it updates in Unity( Since the save files area based in the asset folder in unity ) With the default input tile it works fine, but when i automap and save it dissapears

even though its based in the same structure as the other tile
(Seperated into folders)


From the error in your screenshot, it sounds like Unity can’t find the tileset that contains the output tiles. Make sure that Tileset file is where Unity is looking for it.

Edit: Or is it the prototype tileset it can’t find? In that case, that’s extra weird xP But the solution is probably the same: Make sure the tilesets and .meta files are all where Unity expects them.

I tried using a different TileSet which was created the same way as the template ones and it doesnt show the error anymore, but tileset is still invisible for some reason

bfore applying Automap and saving

and after applying Automap and saving
very strange

1 Like

I’m afraid I can’t help with this, as I don’t use Unity, sorry. Maybe someone else can.

Is the image for the output tileset imported properly in Unity?

When you close and reopen the map in Tiled, are the tiles there? They should be, but I have seen some reports of weirdness with saving Automapping results.

Does it work if you put your output and input tiles all in one tileset?

1 Like

I appear to have solved this, Not sure if this is a bug or my doing but for some reason What i noticed is sometimes Tiled stop receiving input from the Keyboard
so ctrl+s didnt register so it didnt actually save after Automapping

1 Like

Ah. The tab shows whether the map has been saved (unsaved maps have a *), so when debugging this sort of thing, you should keep an eye on that.

The map not saving doesn’t explain why saw a difference in Unity before and after Automapping, however. The map should’ve just stayed looking like the prototype in Unity, shouldn’t it?

1 Like

If i click on Automap but dont actually save the Tilemap it cofuses Unity… i think?
So it shows blank even though there is no error.

Also one more question, I automapped all of my tiles to tile ID X
But now i want to change all of these tiles to tile ID Y ,
But changing it in the rules map doesnt seem to overwrite it, only by adding new Tiles in the tile map it does update
Is there a way to overwrite previous automapping?

What i mean is the Snowtiles are the old ones after Automapping with that tile, but now i want to change all of the tiles to the new black one, but it only works if i re-add tiles


There are two main approaches you can take:

  • Add your output tiles as inputs to your rules, or use the NonEmpty special tile instead of a specific prototype tile, so the rules will accept any tile.
  • Output to a separate layer, so your prototype layer remains unchanged. If you do this, you may want to add a rule to erase tiles from the output layer(s) where the prototype is empty, so subsequent Automapping can respond to the current shape of the prototype.

Also, just in case: if this is meant to be a one-off change from snow to black, you can use the Select Same Tile tool to select all the snow tiles, and then shift+Bucket Fill to fill that selection with the black tile.

1 Like

I see,I’ll try, thanks alot.

1 Like