How to fix the size of my map?

Hello, I’m totally new to this program and while trying to make a map for stardew valley I happened upon an issue that I don’t know how to fix. I opened a map to edit and changed it to infinite map so I had more space to work with, but now that I finished and saved it, upon opening it again it has a weird black space on top. I don’t have much experience so I don’t know how to fix it, please help. :sweat_smile:

It looks like at least some of your layers are Offset. If this is not intentional, select all of them, and set their Offset X and Offset Y layer properties to 0. You can also check and fix the layers’ offsets one by one, if you prefer.

If the map is still weird after that, you have a few options to resize it to the size it’s meant to be:

  • Map > Resize Map to set a specific size.
  • Select the area you want to keep, and Map > Crop to Selection, which might be quicker and easier in this case.
  • Map > Autocrop will trim any empty space on the edges, if the cells are actually empty

You should probably also use the first two of those when you want more space in your map instead of enabling Infinite mode, so that you can maintain control over the size and position of things.

1 Like