Issue when exporting Isometric Map to Unity


I’m having an issue with Tiled + Tiled2Unity, I followed some tutorials on YouTube but I still have the same problem. I’m searching in all forums I can but I don’t find a solution.

Here is my map made with Tiled. No problem, it looks perfect for me.


But when I use Tiled2Unity to export it to my Unity scene, and I drag and drop it, it looks like that in it.

Borders you see in Brown are borders of grass tiles.


If someone knows this issue, how to fix it…

Thank you in advance,


It looks like your tiles are not rendered in the right order, causing the tiles to overlap each other in the wrong way. Try looking for an option in Tiled2Unity that would affect the rendering order. If it doesn’t exist yet, hopefully @Seanba can help you.

Thank you for answering. I was looking for the keyword “rendering order” and I found a topic that talks about it in Tiled2Unity GitHub, and @Seanba answered, so I asked about a solution there. I hope there is.

But why my atlas is giving this kind of issue, and not the atlas that other people are using ?
It could be useful to know that to correct my atlas, and to have a correct result.

Maybe their tiles do not have an overlapping area? Cause in that case the rendering order does not matter. If they do, then there must be some solution already implemented.

An overlapping area between tiles? Mine don’t have too I mean.

I use this tiles :
Could you tell me if it concerns what you’re talking about? Thank you !

I think it’s because map tiles settings are 64 pixels width and 32 pixels height. But my tiles are 64 pixels width and 64 pixels height. And I can’t have 32 pixels height in my tiles because of grass graphics that exceed 32 pixels height.

This may be the classic Tiled2Unity issue with seams. I recently rebuilt Tiled2Unity from the ground up (now called SuperTiled2Unity) in order to fix issues like this.

1 Like