New to Tiled - having trouble with first tileset

Greetings folks - I’m assuming in advance I’m having nothing more than noob issues, but I’ve watched the tutorials, done the research and just can figure out how to import this tileset appropriately and get it working.

The tileset I’m trying to bring in is this one:https://cuddlyclover.itch.io/fantasy-hex-tiles. As you can see in the creator’s description, they give these instructions for importing to Tiled:

Blockquote This tileset was made to use be used in Tiled set to Hexagonal orientation, with 32 tile width, 28 height, and 16 side length . There’s also an offset of 2 on the Y axis in the tileset’s properties.

Further down in the comments, a poster offers a bit more detail:

Blockquote Finally, someone correct me if I’m wrong, but the Tile Properties setting(s) for these tiles is Orientation Othogonal, Grid Width 32px, Grid Height 48px, Drawing Offset (0, 2); Map Properties setting(s) need to be Orientation Hexagonal, Tile Width 32px, Tile Height 28px, Tile Side Length 16px, Stagger Axis X.

I’ve followed all the directions and having the following results.

The empty map looks right; like a normal empty hex map. Map properties I’ve setup:

On the tileset - here’s where I start seeing things not working. I pull up the tileset and go to properties and update based on the above guidellines:

As you can see, I’ve updated properties with the right settings, but the greyed out properties below don’t change. Since it’s greyed out, it makes me think this is more informational (e.g. “here are the properties I imported from the image - feel free to override”), but don’t know.

But then when go back to the map and try to use the tiles, things seem off. Looking at the tile window, you can see from the horizontal line, it definitely looks like the icons haven’t been sized vertically correctly:
image

The blue shading is me trying to select the top left icon. As you can see, it only selects the top half or so. The spacing is definitely off as each row of icons has more and more of the icon in that top half as I move down the sheet.

Sorry for the long post - just wanted to provide enough information for anyone willing to help. Thanks in advance - the app seems great and I’d love to use, but frustrated.

:

Playing around a bit more this morning, when I open the tileset, then go to Tileset > Tileset Properties, when I change a parameter, nothing changes in the preview below. I’ve tried some ridiculous parameter updates to no effect. Is these a step I’m missing to make parameter changes take affect?

Tile sizes can differ between maps and tilesets. For the map, it’s the area occupied by the tile, not including the extra bits that stick out, and it looks like you’ve entered this correctly. For the tileset, it’s the bounding box of the entire tile, the rectangle size that the tilesheet needs to be cut up into.

Although you put the grid width and height, notice how in the image properties, the tile height is still incorrect at 28. This is what’s causing the issue. You need to change that to 48. You can edit the value by clicking the “Edit” button on the Image property.

1 Like

Thank you eishiya - I think I just got to the same place. In my view, all the properties under Image are greyed out and I don’t see anywhat to edit them. I’m sure it’s right in front of me, but can you point me in the right direction?

Oh - there it is. I was trying to edit an individual property - but the edit option is right on the image. Thanks for the help.

1 Like