Please help! error loading objects when tried to open a map


(Nala Mods) #1

I tried to open a map of game mini militia. but when i opened it the objects(gun,bomb) are not in the right place it should be. after a long strugle i placed each object in the right position but after compiling game the objects are still i the wrong position.please see this video and say how to get object in the right place like that( https://www.youtube.com/watch?v=yMIDiNywZEs). see the map at 1.11 it worked fine now see mine


(Nala Mods) #2

please help me


(Thorbjørn Lindeijer) #3

From your screenshot it is clear that the object coordinates are all divided by 2, or that the tile size has been multiplied by 2. Since the general structure is correct but the whole set of objects is scaled down into the top-left quarter of the map.

Could it be, that there are two versions of each map, one of which is adjusted for higher DPI so it would be using larger tile graphics?

In any case, this is really a question for the developer of Mini Militia. Or try asking “Hack Vack”, the author of the video you linked, who I see is also answering questions in the video comments.


(Nala Mods) #4

Can u please say then how to double the coordinate of object


(Thorbjørn Lindeijer) #5

There is no way to do this precisely in Tiled. Best you could do is select all objects and scale up the lot until they appear to be roughly where they should be.

However, you should rather try to avoid needing to do this, which is why I’m telling you to contact people who know this game and how it uses Tiled.


(Nala Mods) #6

Is this because of my PC or tiled


(Thorbjørn Lindeijer) #7

This is neither a problem with Tiled nor with your PC. Please ask the other people for help!


(Nala Mods) #8

Hack vack solved it and thanks for ur interest in helping me


(Thorbjørn Lindeijer) #9

That’s great! Please also feel free to let us know what the problem was. Maybe somebody else will run into this topic. Besides that, I’m curious as well!


(Nala Mods) #10

That game files contain 3 folder for hd,hdr,SD phones

So open all three and one will working fine